GWT, aplikacja na serwerze JSP

0

Witam serdecznie,
mam problem z moją aplikacją napisaną w GWT-Ext.
Buduję war`a, za pomocą eclipse, wrzucam na serwer, aplikacja wydaje się działać, wyświetlane jest okno główne, zakładki itp, ale wysyłanie wiadomości mailowych (działa podczas uruchamiania app w eclipse), nie działa tak jak powinno, za każdym razem wyrzuca okienko z napisem, wiadomośc nie została wysłana, pomimo tego, że wpisuję dokładnie te sane dane, co w hosted mode w eclipse...

korzystam oczywiście z javamail\

może brakuje jakiejś biblioteki ? nie mam jednak pojęcia jakiej, oraz jak ją umieścić, aby aplikacja umieszczona na serwerze działała i bezproblemowo wysyłała wiadomości mailowe.

Macie jakieś pomysły ?

0

A co mówią logi serwera?

0

wrzucę Ci to, co mam, do niczego więcej chyba nie mam dostęu

catalina_2009_02_11.log

Feb 11, 2009 12:00:25 AM org.apache.catalina.startup.Catalina stopServer

SEVERE: Catalina.stop:

java.net.ConnectException: Connection refused

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)

at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

at java.net.Socket.connect(Socket.java:520)

at java.net.Socket.connect(Socket.java:470)

at java.net.Socket.(Socket.java:367)

at java.net.Socket.(Socket.java:180)

at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:409)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:337)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:415)

Feb 11, 2009 12:00:32 AM org.apache.catalina.core.AprLifecycleListener init

INFO:

Feb 11, 2009 12:00:32 AM org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-7107

Feb 11, 2009 12:00:32 AM org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 796 ms

Feb 11, 2009 12:00:33 AM org.apache.catalina.core.StandardService start

INFO: Starting service Catalina

Feb 11, 2009 12:00:33 AM org.apache.catalina.core.StandardEngine start

INFO: Starting Servlet Engine: Apache Tomcat/6.0.14

Feb 11, 2009 12:00:33 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive VMPC.war

Feb 11, 2009 12:00:34 AM org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-7107

Feb 11, 2009 12:00:34 AM org.apache.jk.common.ChannelSocket init

INFO: JK: ajp13 listening on /0.0.0.0:5107

Feb 11, 2009 12:00:34 AM org.apache.jk.server.JkMain start

INFO: Jk running ID=0 time=0/31 config=null

Feb 11, 2009 12:00:34 AM org.apache.catalina.startup.Catalina start

INFO: Server startup in 1591 ms

localhost_2009_02_11.log

Feb 11, 2009 12:00:34 AM org.apache.catalina.core.ApplicationContext log

INFO: ContextListener: contextInitialized()

Feb 11, 2009 12:00:34 AM org.apache.catalina.core.ApplicationContext log

INFO: SessionListener: contextInitialized()

Feb 11, 2009 12:00:34 AM org.apache.catalina.core.ApplicationContext log

INFO: ContextListener: attributeAdded('org.apache.catalina.Registry', '[email protected]')

Feb 11, 2009 12:00:34 AM org.apache.catalina.core.ApplicationContext log

INFO: ContextListener: attributeAdded('org.apache.catalina.MBeanServer', '[email protected]')

no i jeszcze

catalina.out

 Feb 11, 2009 12:00:32 AM org.apache.catalina.core.AprLifecycleListener init

INFO:

Feb 11, 2009 12:00:32 AM org.apache.coyote.http11.Http11Protocol init

INFO: Initializing Coyote HTTP/1.1 on http-7107

Feb 11, 2009 12:00:32 AM org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 796 ms

Feb 11, 2009 12:00:33 AM org.apache.catalina.core.StandardService start

INFO: Starting service Catalina

Feb 11, 2009 12:00:33 AM org.apache.catalina.core.StandardEngine start

INFO: Starting Servlet Engine: Apache Tomcat/6.0.14

Feb 11, 2009 12:00:33 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive VMPC.war

Feb 11, 2009 12:00:34 AM org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-7107

Feb 11, 2009 12:00:34 AM org.apache.jk.common.ChannelSocket init

INFO: JK: ajp13 listening on /0.0.0.0:5107

Feb 11, 2009 12:00:34 AM org.apache.jk.server.JkMain start

INFO: Jk running ID=0 time=0/31 config=null

Feb 11, 2009 12:00:34 AM org.apache.catalina.startup.Catalina start

INFO: Server startup in 1591 ms

pozostałe logi host_manager, magager i admin są puste

// ===================================================
Problem tkwił w złym pliku web.xml, W projekcie są dwa, jeden w katalogu Tomcat (sądziłem, że o ten chodzi), drugi w Katalogu WebContent, i tu był pies pogrzebany, poszperałem po google, jak dokładnie usatwić GWT RPC (komunikację klient-server) i wszystko śmiga :)

// nic dziwnego, że serwer nie wyrzucał żadnych błędów, klasa odpowiadająca za wysyłanie maila, nie była w ogóle wywoływana :p

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0