Problem z uruchomieniem SceneBuilder

0

Dzień dobry, mam problem z uruchomieniem SceneBuildera w InteliJ IDEA. Jak na zamieszczonym zdjęciu. screenshot-20190906185732.png

Co może być przyczyną takich komunikatów ?

0

Nie zaznaczyłem, iż jestem zielony w programowaniu. Mam nadzieję, że chodziło o to: screenshot-20190907102527.png

1

To znany problem (1, 2).

Miałem u siebie to samo, można to obejść w ten sposób (poradnik dla Window$).

  • tworzymy zmienną IDEA_JDK wskazującą na Javę 8
    screenshot-20190907120534.png

  • uruchamiamy IDE za pomocą idea.bat (w moim przypadku C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2\bin).

0

Działa ! Dziękuję : )

Pozdrawiam

0

Mam podobny problem.
Różnica u mnie jest taka, że moja zmienna środowiskowa to JDK 1.8.0_201 zamiast JDK 1.8.0_221

Link do screena : intellj.png

0

Moja drobna uwaga, po kilku dniach łatwiej mi się używa zewnętrznego SceneBuilder`a.

0

Może spróbuję. Ogólnie teraz mi działa w miarę w porządku, ale mam kolejny problem: przy dodaniu w pliku fxml onAction="buttonAction" (ewentualnie z # przed nazwą - różne wersje widziałem i próbowałem tutaj zastosować) kompilator podświetla mi ten element i pokazuje błąd "Page language not specified".

Poprawiłem importy w kontrolerze, jednak w przypadku buttona i onAction nic to nie dało (natomiast podświetlały mi się też inne elementy tj. TextField i Label, a dzięki odpowiedniowi importowi - błędy do tych pól zniknęły).

Ktoś podpowie? Z tą metodą związaną z aktywowaniem przycisku już się męcze parę dni.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0