instalacja CMS'a coyote

0

Nie wiedziałem gdzie to napisać, więc dałem tu...
Podczas instalacji na localhoscie coyote-0-9-2-stable (wersja stabilna 0.9.2)

Wywaliło parę komunikatów

PHP Notice in file c:\usr\krasnal\www\4p\common.php on line 150: Undefined index: UNAVAILABLE
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 174: array_pop(): The argument should be an array
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 174: array_pop(): The argument should be an array
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 174: array_pop(): The argument should be an array
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 178: Undefined variable: news_time
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 178: array_multisort(): Argument #1 is expected to be an array or a sort flag
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 183: Invalid argument supplied for foreach()
PHP Notice in file c:\usr\krasnal\www\4p\index.php on line 368: Undefined index: user_level

Jak to poprawić?

I mam jeszcze jedno pytanko skąd można pobrać aktualną wersje Coyote 0.9.3-pre3 ?
Bo coś znaleźć nie mogłem....

0

Nową wersję pobierzesz bezpośredni z cvs.

Co do komunikatów - w configu ustaw DEBUG na False.

0

Dziękuję za odpowiedz

A mógłbym uprzejmie prosić o dokładny link download?
Bo zalazłem tylko to http://cvs.4programmers.net/cgi-bin/cvsweb/coyote/

Sorki troszkę się nie orientuje w tym

0

Na dole masz Download in tar ball or zip

0

jak zainstaluje cmsa to co trzeba zrobić żeby dobrze chodziły linki?
np. link do artykułów Delphi jest taki http://127.0.0.1/~4p/Delphi/Artykuły
a w skrypcie nie ma w ogóle folderu delphi w tym miejscu więc nigdzie mnie nie przeniesie...

w ogóle całe menu "Katalog" nie chce działać rozumiem że nie ma w bazie artykułów z 4p ale chciałbym żeby to działało normalnie jak 4p tyle że bez artów

0

Musisz mieć zainstalowany moduł mod_rewrite. Możesz też tak jeździć: text.php?subject=Delphi/Artykuły :)

0

Zainstalowany moduł mod_rewrite?
Poczytałem troszkę w Internecie na temat mod_rewrite i już wiem, do czego służy
Ale czy trzeba to instalować? Jak ma się podstawową wersje krasnala (serwer)?
Czy masz na myśli o skonfigurowanie?

0

w pliku konfiguracyjnym http.conf serera apache musisz miec "odkomentowane" linijki

LoadModule rewrite_module modules/mod_rewrite.so

AddModule mod_rewrite.c

generalnie wszystko jest na google..

0
Kooba napisał(a)

AddModule mod_rewrite.c

dyrektywa usunięta w Apache'u 2.0.11

//edit:
Tez mam z tym (postawieniem Coyote'a) troche problemow - stoi tylko jest problem z (chyba) mod_rewrite. Coś nie za bardzo działa, jeszcze nie wiem w czym rzecz, bo np. homepage na localu mi ładnie działa. Nie zagłębiałem się w to jeszcze, ale przy okazji tematu dorzucę screeny, moze kto ma juz gotowe rozwiązanie.

dla forum otrzymuję coś takiego:
user image

dla artów:
user image

z góry dzięki za pomysły ;)

WAMP 1.6.0 => PHP 5.1.1 + Apache 2.0.55 + MySQL 5.0.17</image>

0

Drugi screen: dodaj pole article_id do odpowiedniej tabeli. (INT)

Pierwszy screen: Wina MySQL 5. Ma lekki problem z JOIN-ami.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0