potrzebuje pomocy!!!!!!!

0

hi.
Jestem początkującym webmasterkiem (czytaj zielonym) i mam stworzyc baze danych w mysql znalazlem jakąś książkę i staram sie na jej kodach źródłowych stworzyć tą baze.Znalazłem skrypt na dodawanie rekordów, lecz niestety nie działa.Czy jakiś master mógłby mi podpowiedzieć dlaczego?? Mam zainstalowany Foxserwer i nic tam nie konfigurowałem, bo nie mam pojęcia o tym.Bardzo prosze o pomoc !!!!!!!!!!!!!! Oto ten skrypt

Baza Danych

!!!!!!!!!

0
  1. Źle składnia if... powinno byc tak:
    if(!(warunek1) || !(warunek2)) itd...
  2. Po co stałe połączenie z bazą?
    Z tym trzeba uważać bo... zasmieca server
0

na mój gust masz register_globals na off, spróbUj zamist
$zmienna użyć $HTTP_POST_VARS['zmienna'] albo $_POST['zmienna']
i analogicznie z GET czy COOKIE, ale to tylko tak na pierwszy rzut oka :-D

0

Mi się zdaje że tak jest poprawnie...
Przynajmniej wszędzie tak robią... i chyba bez tego nie zadziała
Jesli sie myle to sorry

Ale ma to tez na znaczeniu gdy jest && bo czasami jakos dziwnie zwraca false gdy powinno true

0

Dziękuje serdecznie panowie mam nadzieje że pomoże.

0

$db = mysql_pconnect("localhost", "root");

ma byc connect nie pconnect

0

Poza ty msamo zapytanie nie jest poprawne:

$zapytanie = "insert into dane (Nazwisko,Imie,Adres,Data_przyjecia,Plec,Waga,Wzrost,Noga,Schorzenie) values ('$Nazwisko','$Imie','$Adres','$Data_przyjecia','$Plec','$Waga','$Wzrost','$Noga','$Schorzenie')";

powinno byc:

$zapytanie="INSERT INTO dane VALUES('$Nazwisko','$Imie','$Adres','$Data_przyjecia','$Plec','$Waga','$Wzrost','$Noga','$Schorzenie')";

0

Kicek, widze że jesteś nowy, więc piszę na początku twojej kariery forumowicza, pisz <font size="12"><font color="red">KONKRETNE TEMATY i NIE POPEŁNIAJ TRAGICZNYCH BŁĘDÓW ORTOGRAFICZNYCH</span></span> !! z tymi błędami to tak na przyszłość :-)

0

Poza ty msamo zapytanie nie jest poprawne:
$zapytanie = "insert into dane (Nazwisko,Imie,Adres,Data_przyjecia,Plec,Waga,Wzrost,Noga,Schorzenie) values ('$Nazwisko','$Imie','$Adres','$Data_przyjecia','$Plec','$Waga','$Wzrost','$Noga','$Schorzenie')";
powinno byc:
$zapytanie="INSERT INTO dane VALUES('$Nazwisko','$Imie','$Adres','$Data_przyjecia','$Plec','$Waga','$Wzrost','$Noga','$Schorzenie')";

Nie zgadzm się - obydwa są poprawne!

0

hmmm... skoro tak twierdzisz, ja poki co nie mam gdzie tego sprawdzic a w klingach ktore czytalem bylo jak napisalem. admin musi postawic serwa to sobie obadam :)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0