Drupal vs. home.pl

Odpowiedz Nowy wątek
2011-07-26 16:32
0

Witam!

Mam następujący problem, a mianowicie po ręcznej iunstalacji Drupal'a na serwerze wykupionym w home.pl, nie ładuje się grafika, tylko sam tekst. Nie ma natomiast problemów z jego działaniem tzn. chodzi tu o problemy z tłumaczeniem interfejsu - wszystko działa, ale w formie teksotwej(bez jakiegokolwiek obrazka wyświetlonego na stronie).

Pliki Drupala są w specjalnym folderze,a domena jest przekierowywana bezpośrednio do tego folderu. Nie jestem w stanie zmienić żadnych ustawień w pliku settings.php (chodzi o przypisanie pełnego adresu do folderu, w którym są pliki do zmiennej $base_url) z poziomu połączenia FTP, gdyż po instalacji i stworzeniu bazy danych drupal automatycznie zmienił prawa dostępu do tego pliku na chmod 755 (tylko odczyt). To samo jest z plikiem .htaccess którego też nie jestem w stanie zmodyfikować.

Czy ktoś z Was miał podobny problem i może udzielić mi jakichś wskazówek aby rozwiązać ten problem?

Pozostało 580 znaków

2011-07-26 18:08
0

To ustaw mu innego chmoda albo skasuj i prześlij jeszcze raz poprawiony. Bez modyfikacji tych plików nic nie osiągniesz.

Pozostało 580 znaków

2011-07-26 19:31
0

hmm... tylko sęk w tym że nie jestem w stanie dostać się konsolowo do ftp'a na home.pl żeby zmienić ten poziom uprawnień :/

Istnieje jakiś inny sposób na zmiane uprawnień pliku na ftp poza dostępem z konsoli?

Pozostało 580 znaków

2011-07-26 19:43
0

Jeśli serwer wspiera chmod możesz walnąć w wierszu poleceń total commandera "SITE chmod 777 settings.php" albo przez Files -> Change Atributes

Pozostało 580 znaków

2011-07-27 09:48
0

jak to nie jesteś w stanie?
przecież home.pl normalnie oferuje możliwość połączenia z serwerem przez FTP

możesz także wgrać skrypt php i przez skrypt php zmienić zarówno zawartość pliku jak i jego uprawnienia

edytowany 1x, ostatnio: TorchLight, 2011-07-27 09:49

Pozostało 580 znaków

2011-07-27 11:40
0

nie byłem w stanie wywołać linii komend(mimo iz program umożliwiał taką opcję) korzystając z programu FileZilla, użyłem Total Commandera i poszło, ustawienia chmod zostały zmienione :)

ustawiłem base_url w pliku settings.php i skasowałem linijki dotyczące filtrowania plików gzip z pliku .htaccess i działa :)

edytowany 2x, ostatnio: sim-ns, 2011-07-27 12:40

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0