Brak tensorflow-gpu po instalacji.

Odpowiedz Nowy wątek
2018-12-17 16:05
0

Cześć
https://gist.github.com/mari-linhares/cef4cb3440408e44963d1447a7db5ae0

Próbuję zainstalować tensorflow-gpu, ale niestety się nie udaje(robie wszystkie kroki z linku powyzej).
title
GTX 1050
UBUNTU 18.04

test gpu install

python -c 'import torch; print(torch.rand(2,3).cuda())'
tensor([[0.3205, 0.1794, 0.9620],
        [0.6146, 0.5109, 0.9467]], device='cuda:0')

Verify the install:

(your_Env_Name) [email protected]:~$ python3 -c "import tensorflow as tf; tf.enable_eager_execution(); print(tf.reduce_sum(tf.random_normal([1000, 1000])))"
2018-12-17 15:53:37.058120: I tensorflow/core/platform/cpu_feature_guard.cc:141] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA
2018-12-17 15:53:37.145892: I tensorflow/stream_executor/cuda/cuda_gpu_executor.cc:964] successful NUMA node read from SysFS had negative value (-1), but there must be at least one NUMA node, so returning NUMA node zero
2018-12-17 15:53:37.146289: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1432] Found device 0 with properties: 
name: GeForce GTX 1050 major: 6 minor: 1 memoryClockRate(GHz): 1.493
pciBusID: 0000:01:00.0
totalMemory: 3.95GiB freeMemory: 3.63GiB
2018-12-17 15:53:37.146302: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1511] Adding visible gpu devices: 0
2018-12-17 15:53:37.326699: I tensorflow/core/common_runtime/gpu/gpu_device.cc:982] Device interconnect StreamExecutor with strength 1 edge matrix:
2018-12-17 15:53:37.326727: I tensorflow/core/common_runtime/gpu/gpu_device.cc:988]      0 
2018-12-17 15:53:37.326732: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1001] 0:   N 
2018-12-17 15:53:37.326931: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1115] Created TensorFlow device (/job:localhost/replica:0/task:0/device:GPU:0 with 3349 MB memory) -> physical GPU (device: 0, name: GeForce GTX 1050, pci bus id: 0000:01:00.0, compute capability: 6.1)
tf.Tensor(-568.367, shape=(), dtype=float32)

gdy wyjde juz z your_Env_Name:

python3 -c 'from tensorflow.python.client import device_lib; device_lib.list_local_devices()'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ModuleNotFoundError: No module named 'tensorflow'

Bardzo zastanawia mnie nvidia-smi(zalacznik) i CUDA Version:10.0 czy to moze powodowac bledy?

A odpalajac w Pycharm test do tensorflow:

ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory
edytowany 3x, ostatnio: supermario, 2018-12-17 16:14

Pozostało 580 znaków

2018-12-17 17:14
0

Ja mam tensorflow-gpu z cuda 9.0, z nowszymi coś nie stykało, ale to było dość dawno jak instalowałem.
No i cudNN coś koło 7.2, i to na bank działa, bo używam, ale oni trochę wolniej aktualizują kompatybilność tensorflowa z cuda.
Nie wiem czy 10 już działa sprawnie.

Edit:
Mój process instalacji wyglądał tak:
install cuda 9.0 - z oficjalnej strony
install cudNN 7.2 - oficjalnej strony
pip install tensorflow-gpu - pip python

edytowany 1x, ostatnio: GodOfCode, 2018-12-17 17:49
pip install tensorflow-gpu - pip python??? - supermario 2018-12-17 20:10

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0