Wordpress - dwie wersje jquery - bez kolizji

Odpowiedz Nowy wątek
2018-02-28 11:15
0

Dzień dobry. Mam pewien problem, mianowicie zaczynam pracować na wordpressie aby chociaż trochę zaznajomić się z tym systemem.
Chciałem wgrać interaktywną mapkę na podstronę kontakt (klasycznie) - ściągnąłem do tego plugin "WP google maps" - jest prosty w implementacji, jednakże bez jego konfiguracji mapka się nie wyświetla - muszę w ustawieniach tej wtyczki zaznaczyć opcję :
" Obecna wersja jQuery została zastąpiona wersją 1.11.3 (Kliknij to okno jeśli otrzymujesz błedy zwiazane z jQuery po zaktualizowanie WordPressa do wersji 4.5)"
wtedy działa, ale na ta wersja jquery gryzie się z tą oryginalną którą miałem i nie wszystkie skrypty działają prawidłowo. W jaki sposób mogę zaimplementować dwie wersję jquery w taki sposób, aby niektóre skrypty działały na starszej wersji (jeśli tego potrzebują) a mapka na nowszej ?

Pozostało 580 znaków

2018-03-01 10:57
0

jQuery.noConflict()

Np:


<script src="https://code.jquery.com/jquery-1.12.4.min.js"></script>
<script>
var $1 = jQuery.noConflict();
</script>

<script src="https://code.jquery.com/jquery-2.2.4.min.js"></script>
<script>
var $2 = jQuery.noConflict();
</script>

<script src="https://code.jquery.com/jquery-3.3.1.min.js"></script>
<script>
var $3 = jQuery.noConflict();
</script>

<script>
console.log($1.fn.jquery); // 1.12.4
console.log($2.fn.jquery); // 2.2.4
console.log($3.fn.jquery); // 3.3.1
</script>
edytowany 2x, ostatnio: old_man, 2018-03-01 10:59

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0