Instalacja wtyczek do edytora Atom - prośba o pomoc

Odpowiedz Nowy wątek
2017-09-13 15:22
0

Cześć, potrzebuję pomocy przy konfiguracji wtyczek dla Atom Nuclide.

Zainstalowałem edytor Atom Nucleide. Problem leży w tym, iż nie posiada on wszystkich potrzebnych mi wtyczek, a kiedy szukam jakichś alternatyw w zasobie Społeczności... okazuje się, że nie wystarczy ich tylko zainstalować, trzeba je też w jakiś sposób dostosować - jestem zielony w tym temacie i nie wiem jak mam to zrobić.

Edytora potrzebuję do Webu i brakuje mi w nim autouzupełniania do PHP/HTML/CSS - podstawowe autouzupełnianie jest dobre, jednak brakuje w nim "dopracowania", nie wiem jak to nazwać.. Kolejna sprawa to brak wtyczki sprawdzającej poprawność składni oraz mini mapy.

Chcę skonfigurować następujące wtyczki:

  • autocomplete-php
  • linter + linter-php
  • minimap

i opcjonalnie atom-beautify, a także inne dodatki typu "Must have".
Powyższe dodatki mam zainstalowane, ale mam problem z ich konfiguracją - będę bardzo wdzięczny za chęć pomocy. Te dodatki ułatwiłyby mi pracę.

Wtyczki instaluję przy pomocy GUI Atom->Packages na systemie Windows 10 Home. Po instalacji przy pomocy pobranego ze strony producenta instalatora nie mam żadnego folderu programu na dysku - instalator program zainstalował i nie miałem możliwości np. zmiany lokalizacji itp. rzeczy.
Do np. config.cson dostaję się przy pomocy terminala, skrót: Ctrl+Shift+P

Pozdrawiam

edytowany 2x, ostatnio: furious programming, 2018-01-07 17:04

Pozostało 580 znaków

2018-01-07 16:57
MichWiz
0

Cześć,
Mam podobny problem. Nie mogę poradzić sobie z zainstalowaniem Lintera dla php. Czy ktoś wie jak to zrobić?

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0