Nie mogę uruchomić Apache w XAMPP

2015-02-18 19:40
0

Hej,
jak w temacie, komunikat towarzyszący:

19:20:32  [Apache]  Error: Apache shutdown unexpectedly.
19:20:32  [Apache]  This may be due to a blocked port, missing dependencies, 
19:20:32  [Apache]  improper privileges, a crash, or a shutdown by another method.
19:20:32  [Apache]  Press the Logs button to view error logs and check
19:20:32  [Apache]  the Windows Event Viewer for more clues
19:20:32  [Apache]  If you need more help, copy and post this
19:20:32  [Apache]  entire log window on the forums

Apache mam zainstalowane, usługa jest uruchomiona, nie mogę wejść na localhost ani 192.168.1.1:8090 (8090 to wybrany port)
Co robić? :D

dodanie znacznika <code class="none"> - @furious programming

edytowany 1x, ostatnio: furious programming, 2015-02-18 21:07

Pozostało 580 znaków

2015-02-18 19:54
Rev
0

Masz zrobić dokładnie to, co sam wkleiłeś.


Pozostało 580 znaków

2015-02-18 20:01
0

MySQL startuje Ci normalnie? W pliku xampp\apache\conf\httpd.conf edytowałeś ServerName localhost:80 oraz Listen 80 Zmieniałeś na swoje ustawienia (8090 jak podałeś)? Jeżeli nie to zmień na inny port, a jeżeli tak oraz po wszystkim z głównego katalogu XAMPP uruchom plik setup_xampp.bat. Powinno pomóc. Zrób kopię plików przed zmianami.

edytowany 1x, ostatnio: Arlid, 2015-02-18 20:04

Pozostało 580 znaków

2015-02-18 20:02
0

A nie masz uruchomionej innej usługi, na tym porcie? Dla przykładu IIS? Ten serwer zawsze domyślnie się włącza jeśli go zainstalowałeś.

Wcześniej normalnie uruchomiałeś Apache pod Xampp-em?


Life is Strange

Pozostało 580 znaków

2015-02-18 20:11
0

@Arlid tak, ustawienia są zmienione. MySQL startuje.
Pojawił się nowy komunikat

20:09:20  [Apache]  Problem detected!
20:09:20  [Apache]  Port 8090 in use by ""C:\Program Files (x86)\Apache Group\Apache2\bin\Apache.exe" -k runservice" with PID 9120!
20:09:20  [Apache]  Apache WILL NOT start without the configured ports free!
20:09:20  [Apache]  You need to uninstall/disable/reconfigure the blocking application
20:09:20  [Apache]  or reconfigure Apache and the Control Panel to listen on a different port

Apache blokuje sam siebie?

@lightinside instaluję to po raz pierwszy, raczkuję w temacie

dodanie znacznika <code class="none"> - @furious programming

edytowany 2x, ostatnio: furious programming, 2015-02-18 21:07
Treść błędów wstawiaj w znaczniki &lt;code=none&gt; - furious programming 2015-02-18 21:08

Pozostało 580 znaków

2015-02-18 20:13
0

Sprawdź jakie masz porty ustawione w Control Panelu - może masz inny i stąd jest kolizja. Czasem po zmianie w configu w Control Panelu zostaje stare 80 :( Ustawiałeś również tam? Uruchamiałeś plik setup?

Pozostało 580 znaków

2015-02-18 20:28
0

uruchomienie pliku setup_xampp nic nie dało, w control panelu faktycznie nie było zmienione, ale ta zmiana ta dała tylko pojawienie się z powrotem komunikatu z pierwszego posta

Pozostało 580 znaków

2015-02-18 20:36
0

Dobra. Z tego co pisałeś to dopiero to zainstalowałeś. Więc usuń to co masz i zainstaluj od nowa. Potem tak:

  1. Zrób to co pisałem wcześniej. W pliku xampp\apache\conf\httpd.conf edytujServerName localhost:80 oraz Listen 80 Zamień na 8080. Zapis zplik
  2. Ewentualnie możesz tez zmienić porty do MySQL, ale jak mówisz, ze działa to niekoniecznie.
  3. Uruchom plik setup - powinno chwilę mielić.
  4. Dopiero wtedy uruchom Control Panel i postaraj się włączyć co trzeba :)

Wyłącz także Skype i TeamViewera jeżeli masz uruchomione.

Pozostało 580 znaków

2015-02-18 21:43
0

punkt 1. ok
co do plikusetup_xampp.bat nic nie mieliło, od razu w konsoli wyrzuciło

Sorry, but ... nothing to do!

chyba nie tak to powinno wyglądać?

Pozostało 580 znaków

2015-02-18 21:56
0

Witam, miałem podobny problem i okazało się że skype używa tych samych portów.

U mnie wystarczyło wyłączyć skype i było po problemie ;)

Pozostało 580 znaków

2015-02-19 06:47
Wielki Kot
0

Nawet nie trzeba wyłączać. Wystarczy skonfigurować skype'a żeby używał innych portów.

edytowany 1x, ostatnio: furious programming, 2016-12-13 18:26

Pozostało 580 znaków

Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0