Kompilator nie tworzy pliku .exe

Odpowiedz Nowy wątek
2011-07-26 19:23
0

Witam, używam dev-c++ i biblioteki graficznej allegro, i nie wiem czemu ale po kompilacji programu nie pojawia mi się plik .exe
Pomoże mi ktoś?
Będę bardzo wdzięczny.

edytowany 1x, ostatnio: madmike, 2011-07-26 20:40
Bo on robi kanapki. - O_o 2011-07-26 19:42
Dobrze się czujesz? - Allucard 2011-07-26 19:45
Dev-C++ służy do robienia kanapek generalnie. - Demonical Monk 2011-07-26 20:04
Ale do bułek to już muszę NetBeansa odpalić, choć spodziewałem się że on to fasolkę mi ugotuje ale dziad nie chce :( - O_o 2011-07-26 21:03
ku*wa. może tak powiecie o co wam chodzi , a nie udajecie debili. - Allucard 2011-07-26 21:25
Ale on naprawdę robi kanapki :( - O_o 2011-07-26 23:52

Pozostało 580 znaków

2011-07-26 19:27
jasnowidz
4
Allucard napisał(a)

Pomoże mi ktoś?

http://wizytauwrozki.pl/

Pozostało 580 znaków

2011-07-26 20:02
0

Okey, już tak jakby tworzy plik .exe, tyle że po jego uruchomieniu nic się nie dzieje :<.

edytowany 1x, ostatnio: Allucard, 2011-07-26 20:04
a sprawdzałeś, czy w kuchni podrzucił ktoś kanapki ? Nie kompiluj tyle bo kto to zje ... ;p - lukas_gab 2011-07-26 20:08
Kanapki robi fajne, ale nie zapomnij dodać #include <manuel> bo inaczej nie posmaruje. - O_o 2011-07-26 21:04
Jako programista za dużo ruszać się nie powinniśmy ( który pan wypuszcza swoich niewolników z lochów na spacerniak ? ) tak więc brak manuela wyjdzie nam na zdrowie. ew. można zrobić #define maslo margaryna ;p - lukas_gab 2011-07-26 21:10
A no całkiem zdrowiej, dobrze by było też zrobić #define wolne_rodniki null - O_o 2011-07-26 23:53

Pozostało 580 znaków

2011-07-26 20:05
1
Allucard napisał(a)

Okey, już tak jakby tworzy plik .exe, tyle że po jego uruchomieniu nic się nie dzieje :<.

Wiesz czemu dostałeś w poście wyżej link do wróżki? Bo napisałeś że masz problem. I tylko tyle. Nie znamy żadnych detali, nie pokazałeś ani odrobiny kodu.


Women were the reason I became a monk - and, ah, the reason I switched back...

Pozostało 580 znaków

2011-07-26 20:10
0

kod tu chyba nie ma znaczenia, nie ważne co wpisze i tak po kompilacji pliku .exe nie da się uruchomić( nie pokazuję się żaden błąd)
W sumie nie wiem co mam jeszcze napisać, przy czystym c++ jest wszystko okey.

Pozostało 580 znaków

2011-07-26 20:13
3

Kod nie ma znacznia! Tak! Z fusów ci kur... wywróżę czemu program nie działa. Zanim nie udostępnisz więcej danych to nie ma jak ci pomóc.


Women were the reason I became a monk - and, ah, the reason I switched back...
edytowany 2x, ostatnio: Demonical Monk, 2011-07-26 20:22

Pozostało 580 znaków

2011-07-26 20:25
0

A tak seriously, to pewnie konsola się od razu zamyka, a tego nie dostrzegasz.

A może odpowiesz teraz na moje pytanie?
Wiesz co, ostatnio wchodziłem na stronę i pokazało się 404, ratunku!
Pewnie już mi wirusy komputer zżerają...
Co mam zrobić?!!?!!?!!

Daj nam więcej informacji, to się (może) przestaniemy z Ciebie nabijać.


edytowany 2x, ostatnio: Patryk27, 2011-07-26 20:28

Pozostało 580 znaków

2011-07-26 20:31
0

Pierwszy lepszy kod:

#include <allegro.h>
 
int main() 
{   
    allegro_init();
    install_keyboard();
 
    set_color_depth(32);
    set_gfx_mode(GFX_AUTODETECT_WINDOWED, 640, 700, 0, 0);
 
    BITMAP *buffer = create_bitmap(640, 700);
    clear_to_color(buffer, 0x333333);
 
    rect(buffer, 1, 1, 51, 51, 0x21D059);
    rect(buffer, 2, 2, 50, 50, 0x21D059);
    rect(buffer, 3, 3, 49, 49, 0x21D059);
 
    textout_centre_ex(buffer, font, ALLEGRO_VERSION_STR, 320, 5, 0xFFFFFF, 0x333333);
 
    rectfill(buffer, 50, 100, 550, 600, 0xDF1680);
 
    blit(buffer, screen, 0, 0, 0, 0, 640, 700);
 
    readkey();
 
    destroy_bitmap(buffer);
 
    return 0;
}
END_OF_MAIN();

Gdy uruchamiam przez kompilator wszystko jest okey, lecz kiedy przez plik .exe, nic się nie dzieje.

Co mam jeszcze podać ? ;f

edytowany 1x, ostatnio: Allucard, 2011-07-26 20:31

Pozostało 580 znaków

2011-07-26 20:40
0

Nie pamiętam, ale tam nie ma tak jak w VS opcji debug i release ? Nie sprawdzę bo po jednej burzy siedze pod tygodnia na blueconnecie z transferem 8kB/s ... ;(

potrzebujesz szybkiego neta żeby uruchomić kompilator? ;-) - Azarien 2011-07-27 10:01

Pozostało 580 znaków

2011-07-26 21:25
0

też nie wiem...

Pozostało 580 znaków

2011-07-26 21:30
0

A co ?! Też się z nim komunikujesz za pomocą projekcji astralnej a nie interfacu ? Proste sprawdź, czy ma taką opcje, czy zainstalować ci VNC i ja mam sprawdzić ? Chociaż przy moim necie bezprzewodowym i tak dupa ...

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0