nie moge utworzyc tabeli

2011-04-01 18:50
barni
0

Witam
mama następującą tabele w której chce zamieszczać zdjęcia ale wyskakuje mi błąd co tutaj jest źle?

CREATE TABLE 'galeria' (
'id_zdjecie' INT( 10 ) NOT NULL AUTO_INCREMENT ,
'nazwa_zdjecie' VARCHAR( 255 ) DEFAULT NULL ,
'opis_zdjecie' text,
'link_zdjecie' VARCHAR( 255 ) NOT NULL ,
PRIMARY KEY ( 'id_zdjecie' )
);

błąd:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''galeria' ( 'id_zdjecie' INT( 10 ) NOT NULL AUTO_INCREMENT , 'nazwa_zdjecie' V' at line 1

edytowany 1x, ostatnio: madmike, 2016-12-13 18:26

Pozostało 580 znaków

2011-04-01 18:54
0

Spróbuj bez apostrofów.
Raz trzy godziny szukałem przyczyny błędu, i były nimi właśnie apostrofy...


edytowany 1x, ostatnio: Patryk27, 2011-04-01 18:56

Pozostało 580 znaków

2011-04-01 18:59
barni
0

spróbowalem i dalej nic

Pozostało 580 znaków

2011-04-01 19:05
0

Hm...
Chyba powinno być bez nawiasów (w pierwszej i ostatniej linii) ;]


edytowany 1x, ostatnio: Patryk27, 2011-04-01 19:05

Pozostało 580 znaków

2011-04-01 19:07
barni
0

dalej nico

Pozostało 580 znaków

2011-04-01 19:08
0

Wybierasz bazę danych przed wywołaniem polecenia (upewnienie) ?


Pozostało 580 znaków

2011-04-01 19:12
barni
0

sory nie wiem za bardzo o co ci chodzi ja jestem w mysql zielony jak możecie to sprawccie tą tabeel u siebie i powiedzcie co jest źle

Pozostało 580 znaków

2011-04-01 19:17
1

Tak działa:

CREATE TABLE galeria (
id_zdjecie INT( 10 ) NOT NULL AUTO_INCREMENT ,
nazwa_zdjecie VARCHAR( 255 ) DEFAULT NULL ,
opis_zdjecie text,
link_zdjecie VARCHAR( 255 ) NOT NULL ,
PRIMARY KEY (id_zdjecie))

W każdym razie u mnie...


edytowany 2x, ostatnio: Patryk27, 2011-04-01 19:20

Pozostało 580 znaków

2011-04-01 19:19
barni
0

nie chodzi mi o to ze nie moge sie połączyc, chodzi o to że nie moge utworzyć tabeli i wyskakuje mi ten błąd co napisałem wyzej

Przeczytaj mój post (poprawiłem). Już działa ? - Patryk27 2011-04-01 19:21

Pozostało 580 znaków

2011-04-01 19:39
barni
0

heheh dzieki wielkie

Pozostało 580 znaków

2011-04-01 20:43
0

A jak już o MySQL chodzi, to ja też mam problem. Mianowicie na pewno mam libmysql.dll na dysku, ale jak w TMySQLConnections Acitve daję na True, to mi wywala
Can not Load mysqllib.dll Nie wiem o co chodzi. Pare razy ściągałem z neta, nawet wyciągnąłem z plików programu Zajączek (do edycji html) i ciągle to samo. Wkładałem go do folderu z programem, do Borland/Delphi/Lib, Borland/Delphi/Bin do folderów systemowych I taki błąd ciągle.


Pozostało 580 znaków

Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0