Witam!

Czy ktokolwiek z obecnych pracował przy użyciu Data Binding na Androidzie? Generalnie mam problem z Gradle Scripts, bo nie ważne z jakiego tutorialu korzystam to wali mi błędami na prawo i lewo związku z tym czy znalazła by się osoba która potrafiła by napisać mi (wytłumaczyć mi) co trzeba zrobić od strony Gradle Srcipts aby móc później korzystać z tej biblioteki ?

Obecnie mój app wygląda tak:

 apply plugin: 'com.android.application'
apply plugin: 'com.android.databinding'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.3"

    defaultConfig {
        applicationId "com.example.databindingtest"
        minSdkVersion 19
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.2.1'
}

Zaś DataBindingTest tak:

 // Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.0.0'
        classpath "com.android.databinding:dataBinder:1.0-rc1"
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

A błąd jaki dostaje tym razem wygląda tak:

 Error:Unable to load class 'org.apache.commons.lang3.StringUtils'.
Possible causes for this unexpected error include:<ul><li>Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)
<a href="syncProject">Re-download dependencies and sync project (requires network)</a></li><li>The state of a Gradle build process (daemon) may be corrupt. Stopping all Gradle daemons may solve this problem.
<a href="stopGradleDaemons">Stop Gradle build processes (requires restart)</a></li><li>Your project may be using a third-party plugin which is not compatible with the other plugins in the project or the version of Gradle requested by the project.</li></ul>In the case of corrupt Gradle processes, you can also try closing the IDE and then killing all Java processes.

Pozdrawiam.

Dobra udało mi się ten problem rozwiązać. Okazało się że tutoriale były robione dla starszych wersji, i od gradle 1.5 nie trzeba dodawać żadnych pluginów i classpathów tylko wystarczy zrobić databinding { enable true }. To tak dla potomności. Temat do zamknięcia