D-link pod Linuksa (Fedora Core 5)

Odpowiedz Nowy wątek
2006-07-18 08:49
Osiolek
0

Mam D-link DWL 520+ i mam problem z zainstalowaniem jej na Linuksie (Fedora Core 5). Otóż sterowniki wgrałem za pomocą programu acx100, wykrywa kartę, lecz po wpisaniu komendy iwconfig pojawia mi się coś takiego:

[[email protected] ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

wlan0 IEEE 802.11b+ ESSID:"STA03A899" Nickname:"acx v0.3.35"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:22 Mb/s Tx-Power=18 dBm Sensitivity=176/255
Retry min limit:7 RTS thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

[[email protected] ~]#

Wszystko działa (Link Quality, Signal level po wpisaniu kucza, ip, bramy oraz ip podsiecidziałają (noise level także ale nie zawsze i ok 3/100). Ale nie wykrywa mi access point'a. Nie wiem co zorbić. Może mi ktoś pomoże? Męcze się z tym już ponad tydzień....

Pozostało 580 znaków

2006-07-18 09:47
0

a co pokazuje
iwlist wlan0 scan
oraz
iwconfig -v
?


Sun Certificated Java Programmer 6

Pozostało 580 znaków

2006-07-18 10:01
Osiolek
0

[[email protected] ~]# iwlist wlan0 scan
Warning: Driver for device wlan0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

wlan0     Interface doesn't support scanning : Resource temporarily unavailable

[[email protected] ~]# iwconfig -v
iwconfig  Wireless-Tools version 28
          Compatible with Wireless Extension v11 to v19.

Kernel    Currently compiled with Wireless Extension v20.

wlan0     Recommend Wireless Extension v9 or later,
          Currently compiled with Wireless Extension v20.

[[email protected] ~]#

Pozostało 580 znaków

2006-07-18 14:00
0

No.. mam dokladnie to samo, z tym ze moja karta to WL-3805, googlalem ostatnio o tym i wyczytałem ze jest to spowodowane złą wersję wireless-tools, nie wiem ja sobie dałem spokoj bo i tak mi nie potrzebna ta sieciowka, a Ty pokombinuj z tym wireless-tools


Sun Certificated Java Programmer 6

Pozostało 580 znaków

2006-07-18 14:35
osiolek
0

;-( W tym problem

Już z tym kombinowałem......

Pozostało 580 znaków

2006-07-19 09:27
0
http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html napisał(a)
  1. In the rare cases where your kernel isn't compiled with Wireless Extensions (/proc/net/wireless non-existent), you need to recompile it with Wireless Extensions (CONFIG_NET_RADIO enabled).
  2. After recompiling a kernel with Wireless Extension, you have to recompile your driver or the Pcmcia package as well (and restart it).
  3. All versions of Wireless Tools up to version 26 need to be compiled for the precise version of Wireless Extension present on the system. Starting with Wireless Tools 27, Wireless Tools can handle multiple versions of Wireless Extension without recompile.
  4. The Wireless Extensions and Wireless Tools version numbers will not match with each other. The Wireless Tools and the Wireless Extensions (the underlying API) evolve independantly of each other. The command iwconfig --version gives you the detail of your setup.
  5. Compilation of the Wireless Tools used to be tricky, especially in the header area. I believe this has been fixed for good.
  6. For kernels before 2.2.14/2.3.30, use Wireless Tools version 19.
  7. For kernel after 2.2.14/2.3.30 use Wireless Tools version 20 or greater.
  8. For kernel after 2.6.13 use Wireless Tools version 27 or greater.
  9. The tools and the wireless library are GPL.
  10. In the old time, you could upgrade Wireless Extensions by just changing wireless.h. Starting with Wireless Extensions v12, this is no longer true, you need to apply the full patch to the kernel. See below for the patches.

got it? musisz zainstaować inne wireless-tools... a to że się da pisze tu: http://gentoo-portage.com/net-wireless/wireless-tools


HAKGER - 50% Complete

Pozostało 580 znaków

2006-07-20 18:20
Osiolek
0

Próbowałem, ale nic z tego :/ (wgrywałem róźne mimo, że tam pisze, że dla mojego jądra jest większe od 27 (czyli w sumie 27 i 28)... wczesniejsze nie zabardzo też się kompilują powstaje jakiś błąd)

Lecz jedyne co się zmienia to :

Warning: Driver for device wlan0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

W zależności od wresji Wireless-tools to ta liczba 19 zmienia się (gdy wersja 24 na 14, 27 na 17 itp), to więc wnioskuje że potrzeba wersję większą od tej którą aktualnie mam a w tym problem, ze taka nie istnieje :/

Pozostało 580 znaków

2006-07-20 18:54
0

hmm... dziwne, na gentoo działa ładnie...


HAKGER - 50% Complete

Pozostało 580 znaków

2006-07-21 11:41
Osiolek
0

W wielu tych kursach internetowych pisze, że trzeba sterowniki z winXP przegrać do folderu /firmware i tak też zrobiłem, ale zastanawiam się, bo to jest nowsza wersja, to może gdzieś indziej trzeba je zgrać, albo w ogóle?

Pozostało 580 znaków

2006-07-29 11:21
Osiolek
0

A może za pomocą Ndiswrappera?
Tylko, że jak daje iwconfig (po tym jak zainstalowałęm go pokazuje mi że zainstalował sterownik) wypisuje mi coś takiego:

[[email protected] ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

[[email protected] ~]#

Nie ma tam żadnego wlan0 :/

Pozostało 580 znaków

2006-07-29 12:49
0

a dales
ifconfig wlan0 up ?


Sun Certificated Java Programmer 6

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0