Prośba o sprawdzenie programu

Odpowiedz Nowy wątek
2006-04-18 18:06
0

www.pliki.orge.pl/test.exe

Napisalem biblioteke, ktora zamienia menu programu zapisane w zasobach na OwnerDraw (w WinApi).

Chodzi mi o to, zeby ktos sprawdzil, czy dziala to u niego tak jak trzeba - zwlascza chodzi mi o systemy inne niz WinXP oraz o rozne ustawienia systemowe (typu duże czcionki w systemie itd.)

Pozostało 580 znaków

2006-04-18 18:14
0

Windows Media Center Edition 2005 [spolszczony] - działa jak trzeba, mimo iż męczyłem go na wszelkie znane mi sposoby i style wyglądu. Ładnie to wygląda, swoją drogą.


<font color="red">Konto porzucone</span>

Dzięki wszystkim forumowiczom za lata wspólnych dyskusji; miłej zabawy w programowanie!
Sławomir 'Szczawik' Włodkowski

Pozostało 580 znaków

2006-04-18 18:33
0

Na Windows XP SP2 (schemat Luna, oliwkowozielony, standardowe rozmiary czcionek) wszystko działa dobrze.

Wirtualizowany (więc nie wiem czy tak samo zachowuje się prawdziwy) Windows Millenium Edition generuje błąd:

user image

Pozostało 580 znaków

2006-04-18 18:36
0

Ładnie to wygląda, swoją drogą.

Office2003 ;)

Mysle, ze pod XP/NT/2000 powinno raczej byc ok.... dobrze by bylo jeszcze sprawdzic ME i starsze (pod 9x mialem problem z wyswietlaniem zaznaczenia i nie wiem czy do konca udalo mi sie go rozwiazac).

Pozostało 580 znaków

2006-04-18 18:43
0

Win 98 SE (normalny, nie wirtualny) -> to samo co u Ktosia na wirtualnym ME

Pozostało 580 znaków

2006-04-18 19:28
0

Mysle ze to dlatego, ze program byl skompresowany FSG. Tutaj jest wersja nie skompresowana:

www.pliki.orge.pl/menu.exe

Sprobujcie tego, powinno sie uruchamiac.

Pozostało 580 znaków

2006-04-18 19:30
0

Wine 0.9.7 pod FreeBSD:
http://www.daminet.pl/~wolverine/testowy.png (kursor myszki jest na jakims elemencie - nic po najechaniu sie nie zmienia [cos tam miga, ze niby chce])


Pozostało 580 znaków

2006-04-18 19:36
0

Wersja nieskompresowana - bez zmian.


<font color="red">Konto porzucone</span>

Dzięki wszystkim forumowiczom za lata wspólnych dyskusji; miłej zabawy w programowanie!
Sławomir 'Szczawik' Włodkowski

Pozostało 580 znaków

2006-04-18 19:50
0

Wine 0.9.7 pod FreeBSD

To moze wynikac z tego, ze WinE czegos nie obsluguje.... pewnie jak nastawisz emulacje WinXP/2000 to bedzie ok - jak ustawie w WinXP zgodnosc z win95/98/Me to tez mam tak samo :| A wynika to z tego problemu, o ktorym wczesniej pisalem i nie wiem jak to obejsc - jak sie nie uda to moze kod tu wrzuce - chodzi o to, ze w Win 9x/Me wartosc jednej zmiennej, ktora wskazuje czy item jest zaznaczony ma inna wartosc, niz pod XP/2000/NT - stad wlasnie problemy. Ja mam XP i nie moge sprawdzic sam.

Szczawik napisał(a)

Wersja nieskompresowana - bez zmian.

Czyli tez wszystko ok? Jezeli nieskompresowane tez sie nie uruchamia pod Me/9x, to chyba juz bedzie wina kompilatora, albo nie wiem sam :|

Moze jeszcze by ktos sprobowal odpalic pod 9x/Me nieskompresowana wersje, wtedy bede wszystko wiedziec.

Pozostało 580 znaków

2006-04-18 22:19
0
othello napisał(a)

Moze jeszcze by ktos sprobowal odpalic pod 9x/Me nieskompresowana wersje, wtedy bede wszystko wiedziec.

U mnie pod Win 98 SE wersja nieskompresowana zachowuje się dokładnie tak samo jak skompresowana - czyli nie uruchamia się, z komunikatem jak wyżej u Ktosia.

Pozostało 580 znaków

2006-04-18 23:38
0

Ostatnia rzecz, ktora mi przychodzi do glowy: prawdopodobnie wersje starsze niz Win2000 nie obsluguja zasobow o ID wiekszym niz 32768 - a ikony itemow mialy takie ID.

Ostateczna wersja:

www.pliki.orge.pl/menu2.exe

Chodzilo mi jedynie o sprawdzenie, czy widac zaznaczenie pod kazda wersja Win, ta sprawa z uruchamianiem wyszla przy okazji..........

Jezeli teraz tez sie nie odpali pod win 9x/Me to juz koncza mi sie pomysly :| Format exeka jest przeciez taki sam dla kazdej wersji win o ile wiem :|

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0