FB wsadowe logowanie do bazy

Odpowiedz Nowy wątek
2006-07-21 08:47
0

Witam,

Mam problem ze zreazliowaniem wsadowego logowania do bazy FB. Logowanie z okienka logowania odbywa się bez problemu. Natomiast w przypadku gdy próbuję zrobić to wsadowo otrzymuję komunikat: "connection rejected by remote interface". Przekazywanie loginu i hasła wstawiłem do zdarzenia OnLogin komponentu IBDatabase.

Proszę o pomoc,


# ZIGGY

Pozostało 580 znaków

2006-07-21 12:35
0

kliknijdwa razy na IBDataBase, uzupełnij wszystkie pola a potem zobacz co i jak zostało wypełnione w OI (szczególnie parameters) a potem w OnClick przycisku Loguj wypełnij wg wzoru i już


- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-07-21 12:48
0

Dane login + pass chciałem odczytać jako parametry z rejestru, tak przy podanwaniu danych z ręki działa ...


# ZIGGY

Pozostało 580 znaków

2006-07-21 13:07
0

ech jak krowie na granicy :)

klikasz dwa razy na IBDataBase i wypełniasz wszystko (u mnie np. tak)
user image
klikasz OK i potem w OI klikasz na Params i masz coś takiego:
user image
widzisz zależność?

to potem pod guzika loguj podpinasz:

  ibd1.Params.Clear;
  ibd1.Params.Add('user_name=sysdba'):
  ibd1.Params.Add('password=masterkey');

- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-07-21 14:48
0

Misiekd dziękuję za zaangażowanie, problem jednak leżał gdzie indziej - nazwa parametru w rejestrze była zbyt długa - skróciłem i działa. Kolejne odświadczenie :). Do FB "loguję" się po raz pierwszy, myślałem, że jest jakiś "myk" którego nie mogę znaleźć. Reasumując formatkę Database Component Editor mam pustą :) i inicjuje ją całą parametrami z rejestru. Dzięki,


# ZIGGY

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0