Linijka kodu sie nie wykonuje

0

Szukalem w wyszukiwarce, ale nie znalazlem. Jak juz bylo to prosze krzyczec :)

Mam Delphi 7. Wszystko jest, bylo ok. Mam 6 procedur, podobnych do siebie. W kazdej jest petla for. To jest chyba nie wazne. Problem jest taki, ze nagle omijana zaczela byc linijka kodu. Jest to przyrownanie dwoch zmiennych typu integer. W edytorze kodu nie pojawia sie niebieska gwizadka, ustawiony breakepoint nie 'lapie', a czerwone koleczko zamienia sie na czerowne koleczko z X w srodku. Dalsza czesc kodu jest wykonywana prawidlowo.
Moze juz ktos sie spotkal z takim czyms?
Nie uzywam w kodzie, zadnych super rzeczy - tylko manipulajce stringami. W 4 pozostalych procedurach jest tez przyrownaine i wszystko dziala.

0

jak to nic wielkiego to wyślij na forum, to zobaczymy :-)

0

To może wynikać z optymalizacji kodu przez kompilator. Jest na tyle sprytny, że pewne rzeczy wyrzuca: niektore linijki kodu "nie istnieja", tez niektore zmienne (np zmienna licznikowa w petli for). Dlatego na etapie testowania i debuggingu warto wylaczyc optymalizacje w opcjach kompilacji i przywrocic dopiero przy ostatecznym kompilowaniu projektu.

0

To może wynikać z optymalizacji kodu przez kompilator. Jest na tyle sprytny, że pewne rzeczy wyrzuca: niektore linijki kodu "nie istnieja", tez niektore zmienne (np zmienna licznikowa w petli for). Dlatego na etapie testowania i debuggingu warto wylaczyc optymalizacje w opcjach kompilacji i przywrocic dopiero przy ostatecznym kompilowaniu projektu.

hmm. wylaczylem optymalizacje i rzeczywiscie linijka zostaje wykonana, a breakpointy zatrzymuja sie. To ze program i tak nie dziala jak bym chcial to juz inna sprawa ;-)
Dzieki, zapamietam rade na przyszlosc [cya]

1 użytkowników online, w tym zalogowanych: 0, gości: 0, botów: 1

Robot: Bingbot