4P dziwnie wolno działa / zalicza zawiechy od kilku dni

Odpowiedz Nowy wątek
2018-05-18 21:24
0

Nie wiem, czy to pasuje do Coyote, czy bardziej do Offtopic, więc jakby co to proszę przenieść ;)

Pytanie - czy Wy też zauważyliście, że w ciągu kilku ostatnich dni (nie umiem dokładnie określić ile, ale raczej nie więcej niż tydzień) 4P ma zawiechy/ zamula się?

Żeby nie było, że to wina mojego łącza lub kompa - stwierdziłem to na 4 komputerach (firmowy, domowy stacjonarny oraz dwa laptopy domowe), z czego połowa ma Win10, a druga Mint 18.2. Nie jest to raczej też kwestia łącza, bo dzieje się to zarówno na domowej kablówce (150/20), firmowym światłowodzie (200/200 z gwarancją) oraz LTE z Plusa.
W czasie, kiedy 4P sie zamula, pingi chodzą, a inne strony otwierają się bez zająknięcia.

Stwierdzone zachowanie objawia się długim wczytywaniem elementów dynamicznych (może nie jest to najlepsze określenie, ale zaraz wyjaśnię o co chodzi). Strona się ładuje OK, a na górze widze, że mam kilka powiadomień. Klikam na "dzwoneczek", rozwija się lista, ale jest pusta i ładne kilka sekund trwa, zanim pojawią się powiadomienia. Albo przed chwilą - dodawałem komentarz do jakiegoś postu, wcisnąłem "wyślij" i przez kilka sekund (na pewno więcej niż 5) był napis "wysyłanie" (czy coś w tym stylu - nie pamiętam dokładnie). Czyli jakby AJAX nie wyrabiał...
Ważna uwaga - nie dzieje się to zawsze, czasami chodzi mega OK, a potem nagle się zamuli na chwilę, po czym wraca do stanu normalnego...

Dajcie proszę znać, czy Wy też zauważyliście coś takiego.


That game of life is hard to play
I'm gonna lose it anyway
The losing card I'll someday lay
So this is all I have to say
Wszystko co dotyczy działania serwisu należy umieszczać tutaj. Tak więc dobrą kategorię wybrałeś. - furious programming 2018-05-18 21:56
Dzięki za odp. Nie byłem pewien, ponieważ Coyote to cały projekt, a to o czym pisałem może wynikać np. z zapchanego serwera albo problemów technicznych na wyjściu serwerowni w świat. A tak przy okazji - czy Ty też coś zauważyłeś, czy póki co jestem jedyny? - cerrato 2018-05-18 21:59
Na razie nie, bo „gram w gre” i nie mam czasu się nad tym zastanawiać. :P - furious programming 2018-05-18 21:59
Wszystko przez te i podobne wątki -> https://4programmers.net/Foru[...]zej_pracy?p=1481024#id1481024 Serwis nie był przygotowany pod obsługę ruchu podobnego do wykop.pl :D - loza_szydercow 2018-05-19 20:30

Pozostało 580 znaków

2019-08-09 16:26
2

Ja nic nie mówię, ale:

screenshot-20190809162643.png


"HUMAN BEINGS MAKE LIFE SO INTERESTING. DO YOU KNOW, THAT IN A UNIVERSE SO FULL OF WONDERS, THEY HAVE MANAGED TO INVENT BOREDOM."
mam nadzieję, że to nie miało miejsca przy żadnym z moich postów. Takie marnowanie łapek.. słabo mi :( - cerrato 2019-08-09 16:27

Pozostało 580 znaków

2019-08-10 10:27
0

VACUUM wykonany. Przy okazji zrobiony został upgrade do PHP 7.3. Powinno działać lepiej.

Widziałem jakieś 15 minut temu chwilową niedostępność. Byłem ciekawy, czy zaraz pojawi się info o pracach ;) - cerrato 2019-08-10 10:29
100 ms poki co. Ale ostatnio tez bylo lepiej wiec musze odpukac :p - stivens 2019-08-10 10:31
Pamiętaj też Robalu, że czas podany na dole to jedno, ale realne oczekiwanie na pojawienie się treści to coś całkowicie odmiennego. Nieraz bywało tak, że czekałem kilka sekund na pokazanie się strony, a jak już wskoczyła, to miała czas generowania rzędu kilkaset ms. Ale póki co jest bardzo dobrze. Żeby się tylko nie popsuło za chwilę :( - cerrato 2019-08-10 10:37
O to juz bym bardziej Twojego ISP obwinial - stivens 2019-08-10 10:39
nie ma opcji - występuje w kilku miejscach na różnych kompach i różnych łączach. Także w firmie, gdzie mam światłowód 200/100 z gwarancją. - cerrato 2019-08-10 10:42

Pozostało 580 znaków

2019-08-13 22:10
0

@cerrato: odpowiadam na Twój komentarz do mojego postu w sprawie wolnego przesyłu strony (nie jej generowania). Jeżeli używasz Chrome, to przejdź do narzędzi deweloperskich (na FF oczywiście też są), następnie do zakładki Network. Poniższy screen przedstawia akurat analizę podstrony Praca. Większość zasobów (CSS czy JS) jest w cache więc ściągamy tak naprawdę treść strony.

screenshot-20190813220557.png

Zielony wykres (TFFB) prezentuje tak naprawdę czas generowania strony po stronie serwera. Jak można zauważyć, jest on większy niż czas podawany w stopce strony. Wszystko dlatego, że w stopce prezentowany jest czas generowania strony przez samego Coyote. Do tego dochodzi tutaj żądanie do nginx, następnie do php-fpm oraz ewentualne lagi.

Na niebieskim wykresie przedstawiony jest czas ściągania danego zasobu. Oczywiście używamy HTTP2.

Strona główna forum:

screenshot-20190813221014.png

Jak to u Ciebie wygląda?

muszę to rozkminić, bo u mnie w FF nie mam takich dwóch paseczków jak u Ciebie, tylko kilkadziesiąt elementów składowych. Staram się znaleźć coś podobnego ;) Wsparcie ze strony osób bardziej zaznajomionych w obsłudze tych narzędzi w FF będzie mile widziane ;) - cerrato 2019-08-13 22:38
Na kablu natomiast mam lepsze wyniki (nietrudno się dziwić), ściąganie samej zawartości nie przekracza 40 - 50 ms. - Adam Boduch 2019-08-14 06:40

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 0, botów: 1

Robot: CCBot