Witam wszystkich

Mam następujący problem: mam kod źródłowy pluginu do pewnego programu, ale podczas ładowania tego pluginu program nie potrafi załadować pluginu i wypisuje informacje o tym, że plugin został przygotowany dla starszej wersji programu.
Oczywiście plugin już raczej nie jest wspierany, a program nie zmienił się na tyle, żeby nie działać z pluginem.
Czy jest jakiś sposób na debugowanie biblioteki pluginu, żeby sprawdzić w którym miejscu program sprawdza dla jakiej wersji został przygotowany i ewentualnie w którym miejscu się wysypuje jeżeli istnieje jakaś niekompatybilność.

Z góry dzięki za wszelką pomoc.

Ps. Moje pytanie jest czysto teoretyczne, ale jeżeli potrzeba detali odnośnie aplikacji: program to autocad 2012, a plugin to arxdbg.arx (napisany w C++) umieszczony w pakiecie ObjectARX2012.


"Zębów mądrości używa się tylko wtedy, gdy chce się przełknąć więcej niż jest się w stanie zmieścić do ust"