Problem z WebBrowser...

2002-07-02 18:25
Micha?
0

Witam!{hello}{hello}
Potrzebuję waszej pomocy...WebBrowser.
A więc:
Umieściłem na formie komponen WebBrowser(dokumenty HTML wyświetlają się prawidłowo) i dwa buttony:
'&ltWstecz' (WebBrowser1.GoBack;) ,
'Dalej&gt' (WebBrowser1.GoForward;)...
Wszystko działa prawidłowo, aż po którymś z kolei kliknieciu na np. '&ltWstecz' wyskakuje błąd: "Nie określony błąd." Jestem prawie pewien, że spowodowane jest to tym, że NIE MA już następnej podstrony do wyświetlenia... Jak zrobić żeby co jakiś czas program sprawdzał czy jest następna podstrona do wyświetlenia, a jeżeli nie ma to żeby zmieniał właściwości buttona np. '&ltWstecz' na Enabled:=false; i tym samym zablokował kliknięcie tegoż buttona... Proszę o kodzik, z góry dziękuję i pozdrawiam..
Oh ale się rozpisałem, hehe:)

P.s Przeszukałem FAQ chyba z 4 serwisów i studiowałem różne kody źródłowe i nic:( --Pozdrawiam!
Michał Lipski
E-mail: [email protected]
http://www.delphi.programowanie.prv.pl
GG#: 3742497

Pozostało 580 znaków

2002-07-02 19:12
ZIOMBER
0

znajdź katalog Delphi(numer wersji)\demos\coolstuff

tam jest demo do tego komponętu :) i tam wszystko działa - btw. on kożysta z hisotrii tak jak normalny IE

Ja mam d5 więc u mnie ścieżka jest taka: C:\...\Delphi5\Demos\Coolstuf i tam masz progsik

Pozostało 580 znaków

2002-07-03 15:33
Micha?
0

ZIOMBER napisał:
znajdź katalog Delphi(numer wersji)\demos\coolstuff
&gt
&gt
&gttam jest demo do tego komponętu :) i tam wszystko działa - btw. on kożysta z hisotrii tak jak normalny IE
&gt
&gtJa mam d5 więc u mnie ścieżka jest taka: C:\...\Delphi5\Demos\Coolstuf i tam masz progsik

Ok dzieki, widziałem ten program..--Pozdrawiam!
Michał Lipski
E-mail: [email protected]
http://www.delphi.programowanie.prv.pl
GG#: 3742497

Pozostało 580 znaków

Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0