Problem z PHP

0

Witam,
Mam problem z umieszczeniem kodu php w html. Kod jak jest tylko w PHP to działa, a jak umieściłem go do html to już nie.

Kod HTML:

<!DOCTYPE HTML>
<html lang= "pl">
<head>
<meta charset = "utf-8" />
<title> Zaloguj</title>
<meta name="description" content= test2 />
<meta name= "keywords"content="Cytaty.pl" />
    <meta http-equiv="X-UA-Compatible" content= "IE=edge,chrome=1" />
    <link rel="stylesheet" href="style2.css" type="text/css"/>
    <link href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:700" rel="stylesheet"> 

</head>
<body>
<form action="potwierdz.html" method="post">
    <div id="pyt">
        <center><h1>Odpowiedz na kilka pytań:</h1></center>
        <center><div class="pyt">1. Masz dzieci? <input type="text" name="d1" placeholder="Tak/Nie"></div></center>
        <center><div class="pyt">2. Masz wnuki? <input type="text" name="d2" placeholder="Tak/Nie"></div></center>
        <center><div class="pyt">3. Masz prawnuki? <input type="text" name="d3" placeholder="Tak/Nie"></div></center>
        <center><div class="pyt">4. Jak masz na imię? <input type="text" name="d4" placeholder="Podaj imię..."></div></center>
        <center><div id="butt"><input type="submit" value="Dalej" /></div></center>
    </div>
</form>
</body>
</html>

A tu php umieszczone w HTML:

<!DOCTYPE HTML>
<html lang= "pl">
<head>
<meta charset = "utf-8" />
<title> Zaloguj</title>
<meta name="description" content= test2 />
<meta name= "keywords"content="Cytaty.pl" />
    <meta http-equiv="X-UA-Compatible" content= "IE=edge,chrome=1" />
    <link rel="stylesheet" href="style.css" type="text/css"/>
</head>
<body>
    <?php
    $dziecko = $_POST['d1'];
    echo $dziecko;
    ?>

</body>
</html>

Dodam, że program ma być drzewem genealogicznym dlatego takie pytania.

0

Wystarczy zmienić rozszerzenie z .html na php pliku "Potwierdz" inaczej apache nie wie że ma wykonać ten kod ^ ^

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0