Nie mogę zbudować projektu STM32 w System Workbench

0

Zainstalowałem IDE System Workbench, stworzyłem nowy projekt. Ściąganie firmware'u do mojego mikrokontrolera F103RB nie działało - tylko ściąga pierwsze ~200kb pliku zip i wtedy się zatrzymuje, więc musiałem to znaleźć ręcznie (plik ma tą samą nazwę więc powinien być ten sam) i wypakowałem to w C:\Users[username]\AppData\Roaming\Ac6\SW4STM32\firmwares. System Workbench znajduje firmware w folderze i nie próbuje automatycznie go ściągać; projekt został stworzony. Wtedy ściągnałem toolchain (www.launchpad.net/gcc-arm-embedded/+download) i po instalacji zaznaczyłem checkboxa by dodać program do Path. Teraz kiedy próbuje budować projekt to jest taki błąd: user image i zakładka Console pokazuje to:

10:27:06 **** Incremental Build of configuration Debug for project sluchawki ****
make all 
process_begin: CreateProcess(NULL, echo "Building file: ../startup/startup_stm32f10x_md.S", ...) failed.
make (e=2): Nie można odnaleźć określonego pliku.

make: *** [startup/startup_stm32f10x_md.o] Error 2

10:27:07 Build Finished (took 1s.403ms)
0

Ten username ma spacje albo polskie znaki(zakładam, że pliki są tam gdzie powinny)?

0
alagner napisał(a):

Ten username ma spacje albo polskie znaki?

Username ma polskie znaki i ścieżka ma spacje, ale sprawdzałem to, stworzyłem projekt w ścieżce bezpośrednio na dysku C i to nie robiło różnicy, błąd był taki sam. Nawet by się upewnić, to teraz jeszcze raz spróbowałem.

(zakładam, że pliki są tam gdzie powinny)

Nie wiem o co ci chodzi z tym, ale ten plik "../startup/startup_stm32f10x_md.S" którego zbudowanie się nie powiodło jest w tej ścieżce.
https://www.dropbox.com/s/qap[...]9/startup_stm32f10x_md.S?dl=0
Nie ma jednak pliku z rozszerzeniem .o "startup/startup_stm32f10x_md.o".

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0