Maven deploy problem

Odpowiedz Nowy wątek
2012-07-06 19:12
0

Witam,

mam problem tego typu, że stworzyłem w Eclipse project Maven, czysty. Dodałem jeden plik index.jsp i w nim wpisałem "Hello World". Skonfigurowałem Tomcata w plikach tomcat-use.xml dodałem

<role rolename="manager-gui" /> <user username="test" password="test" roles="manager-gui" />

Do mavenowego setting.xml dodałem:

<id>Tomcat</id> <username>test</username> <password>test</password>

Teraz na pliku pom.xml w projekcie klikam prawym -> Run as -> Maven Build -> w polu goals wpisuje tomcat:deploy

Problem jest taki, że tworzy mi wara ale przed deployem jest taki blad:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2.1.1:war (default-war) on project pl.testowy: Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode) -> [Help 1]

Ma ktoś jakiś pomysł ?

Pozostało 580 znaków

2012-07-06 19:32
mućla
0
Zaki88 napisał(a):

Witam,

mam problem tego typu, że stworzyłem w Eclipse project Maven, czysty. Dodałem jeden plik index.jsp i w nim wpisałem "Hello World". Skonfigurowałem Tomcata w plikach tomcat-use.xml dodałem

<role rolename="manager-gui" /> <user username="test" password="test" roles="manager-gui" />

Do mavenowego setting.xml dodałem:

<id>Tomcat</id> <username>test</username> <password>test</password>

Teraz na pliku pom.xml w projekcie klikam prawym -> Run as -> Maven Build -> w polu goals wpisuje tomcat:deploy

Problem jest taki, że tworzy mi wara ale przed deployem jest taki blad:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2.1.1:war (default-war) on project pl.testowy: Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode) -> [Help 1]

Ma ktoś jakiś pomysł ?

User test tomcata a user test mavena to zueplnie 2 rozne rzeczy bez najmniejszego zwiazku, nie wiem po co to tutaj. Jesli chodzi o deployment, to nie tedy droga.
Blad jest jasny prawda? Twoj webap nie ma web.xml, ani domyslnego w src/main/webapp/WEB-INF/web.xml, ani podanego jawnie jako paramtr do pluginu. Nie wiem jak ta wersja, ale jesli budujesz webapp dla servletow 3.0, to tam nie trzeba web.xml, ale chyba musisz powiedziec pluginowi ze chcesz miec 3.0.

Deployment - musisz skonfigurowac odpowiednio repo do ktorego chcesz deployowac, w pom.xml. Nie, takim repo nie jest tomcat...

Pozostało 580 znaków

2012-07-06 19:55
0

To mój pom.xml:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <groupId>pl.test</groupId>
    <artifactId>pl.testowy</artifactId>
    <version>0.0.1-SNAPSHOT</version>
    <packaging>war</packaging>
    <name>Test</name>

    <dependencies>
        <dependency>
            <groupId>org.hibernate</groupId>
            <artifactId>hibernate-core</artifactId>
            <version>4.1.4.Final</version>
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>tomcat-maven-plugin</artifactId>
                <configuration>
                    <a href="http://localhost:8080/manager">http://localhost:8080/manager</a>
                    <server>Tomcat</server>
                </configuration>
            </plugin>
        </plugins>
    </build>
</project>

Doszedłem do tego, że brak mi pliku web.xml. Ale mam nowy problem:

Failed to execute goal org.codehaus.mojo:tomcat-maven-plugin:1.1:deploy (default-cli) on project pl.testowy: Cannot invoke Tomcat manager: Server returned HTTP response code: 403 for URL: http://localhost:8080/manager/deploy?path=%2Fpl.testowy&war= -> [Help 1]

Pozostało 580 znaków

2012-07-07 13:43
0

Zmieniłem ten kawałek w pom.xml:


<build>
                <plugins>
                        <plugin>
                                <groupId>org.codehaus.mojo</groupId>
                                <artifactId>tomcat-maven-plugin</artifactId>
                                <configuration>
                                        <a href="http://localhost:8080/manager">http://localhost:8080/manager</a>
                                        <server>Tomcat</server>
                                        <username>test</username>
                    <password>test</password>
                                </configuration>
                        </plugin>
                </plugins>
        </build>

I wszystko działa. Do zamknięcia

edytowany 1x, ostatnio: Zaki88, 2012-07-07 13:43

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych 0, gości 1, botów: 0