Witam. JBoss 6.0 wyrzuca mi następujący komunikat:
[org.hibernate.ejb.Ejb3Configuration] Persistence provider caller does not implement the EJB3 spec correctly.PersistenceUnitInfo.getNewTempClassLoader() is null.

Gdy dodam do właściwości pliku persistence.xml właściwość:

<property name="hibernate.hbm2ddl.auto" value="create" />

Wywala komunikatu o braku możliwości połączenia z bazą danych.

Plik persistence.xml wygląda następująco:

<?xml version="1.0" encoding="UTF-8" ?>
<persistence version="2.0"
    xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd">
    <persistence-unit name="tsPU" transaction-type="JTA">
        <provider>org.hibernate.ejb.HibernatePersistence</provider>
        <jta-data-source>java:/EJBTEST</jta-data-source>
        <properties>
            <property name="hibernate.temp.use_jdbc_metadata_defaults" value="false" /> 
            <property name="hibernate.dialect" value="org.hibernate.dialect.Oracle10gDialect" /> 
            <property name="hibernate.show_sql" value="false" />
            <property name="hibernate.format_sql" value="true" />
            <property name="hibernate.generate_statistics" value="false" />
            <property name="hibernate.use_sql_comments" value="false" />
            <property name="hibernate.id.new_generator_mappings" value="true" />
        </properties>
    </persistence-unit>
</persistence> 

Dodam, że JNDI do bazy na serwerze jest dobrze zdefiniowane. Wydaje mi się, że problem jest z provider'em lub dialektem.
Możliwe jest również, że jakiejś biblioteki brakuje mi na serwerze.
Z góry dzięki za wszelką pomoc.

Wykorzystane technologie:
Hibernate, Oracle11gR2, EJB3.0