[Docker][Docker-Compose][]

Odpowiedz Nowy wątek
2019-08-03 18:02
0

Witam ;)

Mam problem z odpaleniem kontener Angular-a na Docker-ze.

Komenda uruchomieniowa: docker-compose up --build -d
Rezultat :
ERROR: for angularcontainer Cannot start service angular: OCI runtime create failed: container_linux.go:348: starting container process caused "exec: \"bash\": executable file not found in $PATH": unknown

Mój plik compose :

version: "3"
services:
  Database:
   container_name: 'mysql_db'
   image: mysql:5.7
   environment:
    MYSQL_ROOT_PASSWORD: secretPassword
    MYSQL_USER: root
   ports:
    - "3307:3306"
  customer:
   build: ./SpringBootCustomer
   ports:
    - "8082:8082"
   depends_on:
    - Database
    - product
  product:
    build: ./SpringBootProduct
    ports:
      - "8081:8081"
    depends_on:
      - Database
  credit:
    build: ./SpringBootCredit
    ports:
      - "8080:8080"
    depends_on:
      - Database
      - product
      - customer
  angular:
    container_name: angularcontainer
    build: ./Web-Ui
    volumes:
      - './Web-Ui:/usr/src/app'
    ports:
      - '4200:4200'
    depends_on:
      - Database
      - product
      - customer
      - credit
    command:
      bash -c "npm install && ng serve --host 0.0.0.0 --port 4200"

Stack podpowiadał pogrzebać w pliku : docker.service
I wyłączyć flagę MountFlag, niestety u mnie takowej nie ma:

[Service]
ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock
ExecReload=/bin/kill -s HUP $MAINPID
TimeoutSec=0
RestartSec=2
Restart=always

StartLimitBurst=3

# Note that StartLimitInterval was renamed to StartLimitIntervalSec in systemd 230.
# Both the old, and new name are accepted by systemd 230 and up, so using the old name to make
# this option work for either version of systemd.
StartLimitInterval=60s

LimitNOFILE=infinity
LimitNPROC=infinity
LimitCORE=infinity

TasksMax=infinity
Delegate=yes
KillMode=process

Czekam na rady ;)

Prośba napisz jakiś temat, czy coś. - Koziołek 2019-08-07 14:55

Pozostało 580 znaków

2019-08-03 18:31
1

Pokaż link do posta na stacku, który kazał ci grzebać w ustawieniach daemona dockera bo nie masz jakiegoś programu w obrazie? :O
Doinstaluj basha do obrazu, zmień bazowy obraz na taki, który ma zainstalowanego basha albo użyj sh zamiast basha.

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0