PHP liip i Mac OS

Odpowiedz Nowy wątek
2015-01-11 12:39
noname00000
0

Chciałbym na macu zainstalować sobie różne wersje php i napisać do tego prosty skrypcik pozwalający na zmianę wersji w dowolnym momencie - mam różne projekty oparte na różnych wersjach. Całość ma być połączona z phpstorm-em i xdebugiem. Jakieś wskazówki? Z góry dziękuję.

Pozostało 580 znaków

2015-01-11 14:02
0

http://getgrav.org/blog/mac-o[...]e-setup-multiple-php-versions

i generalnie multiple php version mac os w google


Pozostało 580 znaków

2015-01-11 19:36
0

już dawno ktoś inny to wymyślił...

https://github.com/phpbrew/phpbrew

Known Issues: For PHP-5.3+ versions, "Building intl 64-bit fails on OS X" - hehe :p - dzek69 2015-01-11 20:36
intl 64-bit nie interesowała autora tematu :P. Poza tym 5.3 to taka zaszłość że szkoda wracać do tej wersji :). Do takich zabaw jest vagrant i puphet. Szkoda zaśmiecać sobie systemu. A i przeskoki między wersjami raczej są bez sensu, bo w najnowszej wersji zazwyczaj są rzeczy z poprzednich wersji, chyba że są deprecated to i tak przez pare buildów istnieją... - sfan 2015-01-11 20:43
5.3+ - dla mnie to oznacza "wszystko nowsze od 5.3"... gdyby było "5.3.x" to byłby inny temat - dzek69 2015-01-11 21:57

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0