delphi, access, hasło w bazie

Odpowiedz Nowy wątek
2006-09-11 14:57

Rejestracja: 17 lat temu

Ostatnio: 9 lat temu

0

Witam.

Napisałem w delphi program bazodanowy który łączy się z bazą w accesie za pomocą komponentów ADO. Program działa jak powinien i wszystko jest ok. Chciałem zabezpieczyć bazę w accesie hasłem, wchodząc do acessa i ustawiając hasło dla bazy.
Następnie ustawiłem w delphi(komponent ADOConnection) hasło dostępu i wybieram przycisk test połączenia a on ciągle wywala mi komunikat "Połączenie testowe nie powiodło się z powodu błędu w inicjowaniu dostawcy. Nie można uruchomić aplikacji. Plik informacyjny grupy roboczej nie istnieje lub został otwarty w trybie wyłączności przez innego użytkownika".
O co w tym chodzi, dlaczego nie chce to działać i jak zrobić aby działało ??

Pozostało 580 znaków

2006-09-11 15:31

Rejestracja: 16 lat temu

Ostatnio: 7 lat temu

0

Lektura


- Ciemna druga strona jest.
- Nie marudź Yoda, tylko jedz tego tosta.
Google NIE GRYZIE!
Pomogłem - kliknij

Pozostało 580 znaków

2006-09-11 17:25

Rejestracja: 17 lat temu

Ostatnio: 9 lat temu

0

Ok. Dzięki. Twój link mi pomógł.

Ale teraz niestety jest kolejny problem. Teraz wyskakuje mi informacja "Niewłaściwa nazwa konta lub niewłaściwe hasło". A wszystko mam prawidłowo poustawiane i znowu nie wiem o co chodzi. Może jeszcze jakąś opcję w delphi trzeba włączyć ?

Szukałem odpowiedzi w tych grupach dyskusyjnych ale nic nie znalazłem.

Pozostało 580 znaków

2006-09-11 17:36

Rejestracja: 17 lat temu

Ostatnio: 9 lat temu

0

Kombinowałem aż wkońcu się udało :-) .

Tak więc:

-w katalogu z programem należy umieścić plik .mdw,
-w opcjach komponentu ADOConnection -> ConnectionString -> Build -> Zakładka Wszystkie, Należy ustawić ścieżkę do pliku
.mdw w opcji Jet OLEDB:System database,
-mimo iż w accessie nazwa użytkownika to Administrator to w Delphi jako użytkownik należy podać Admin, no i hasło takie jak w accesie podaliśmy.

Pozostało 580 znaków

Odpowiedz

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0