znikajaca ikona

0

jak zalaczyc ikone do programu? bo u mnie dziala a u kolegi w ogóle nie ma zadnej ikony, tylko przezroczysty kwadrat

0

A ile kolorów ma ikona? Może ma zbyt dużo kolorów i jego system nie potrafi jej wyświetlić?

0

truecolor, ale poważnie myślisz że to może być przyczyną? kolory nie będą dopasowywane do najbliżych odpowiedników?

0

truecolor, ale poważnie myślisz że to może być przyczyną? kolory nie będą dopasowywane do najbliżych odpowiedników?

0
randap napisał(a)

truecolor, ale poważnie myślisz że to może być przyczyną? kolory nie będą dopasowywane do najbliżych odpowiedników?

Gdy ładujesz ikonę z pliku ikony (*.ico) to system najwyrzej ją błędnie wyświetli (w nieprawidłowych kolorach) ale z zasobów (a tam jest umieszczona ikona programu) to spotkałem się z tym, że mi Win98 nie chciał na Trayu nie chciał umieścić ikonki ze zbyt durzą liczbą kolorów. Wiem, że tobie nie chodzi o ikonę na Trayu ale możę z tym jest podobny numer :-/ Najlepiej dodaj do tej ikonki jeszcze jedną z mniejszą liczbą kolorów i przebuduj projekt. Chociaż wydaje mi się, że w truecolor też powinna być wysietlana, jednak innego pomysłu na razie ja ani jak widać nikt inny nie ma, więc możesz to sprawdzić.
EDIT//Oczywiście ładujesz ikonę przez Project->Options->Application->Load Icon.. ?

0

dziwne, ale rzeczywiście zadziałało przy 256 kolorach. a w trayu wszystko działa ;)

0
randap napisał(a)

dziwne, ale rzeczywiście zadziałało przy 256 kolorach. a w trayu wszystko działa ;)
Windows ma swoje odbicia ;)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0