TCP/IP

Odpowiedz Nowy wątek
2003-07-05 17:20
Log
0

Mam problem.
Chciałem napisać komunikator internetowy, ale
kiedy już był gotowy i przystąpiłem do testów
okazało się że nie działa (nie może ustanowić
połączenia z serwerem). Wszystko dokładnie
kilka razy sprawdziłem, ale nie znalazłem
żadnego błędu. Wtedy postanowiłem ściągnąć
kilka przykładów tego typu programów (kody
źródłowe) przeanalizowałem je dokładnie,
porównałem z moim programem i wszystko się
zgadzało, mam nawet kod źródłowy takiego
komunikatora z płyty pewnego czasopisma,
porównuje i nic wszystko poprawnie, ale co
najlepsze to kompiluje ten komunikator z
czasopisma (bez żadnej ingerencji w jego
kod źródłowy) i co się okazuje też nie działa!!!
To samo z kodami z Internetu między innymi z
tego serwisu.
Nie wiem co jest grane!!! na localhost bez problemu
od razu wszystko pyka a jak chce się połączyć
z innym kompem przez Internet to nie mogę.

Co może być tego przyczyną??? :-[
Źle skonfigurowany protokół TCP/IP czy co.
Ja już nie wiem o co chodzi i dlatego postanowiłem
skonsultować się z bardziej doświadczonymi
programistami niż ja.

PS. Sorry że się tak rozpisałem ale
chciałem dokładnie przedstawić sytuacje.


Jak nie myślisz to nie wymyślisz

Pozostało 580 znaków

2003-07-05 17:29
0

Bez kodu raczej ciężko cokolwiek pomóc..


Pozostało 580 znaków

2003-07-05 17:39
0

Podejrzewam, ze komputer, z którym się łaczysz, nie ma zewnętrznego adresu IP. W takim przypadku nie da się tego naprawić, serwer musi stać na kompie z zewnętrznym IP.

Pozostało 580 znaków

2003-07-05 17:54
Log
0

Nawet jak wpisywałem swój numer IP już podczas połączenia z internetem (nie localhost, ani 127.0.0.1) to też się nie chciał połączyć.
Prubowałem też u siostry (pokuj obok, też ma internet) i nic. te gotowce min. z tego czasopisma też nie działają.


Jak nie myślisz to nie wymyślisz

Pozostało 580 znaków

2003-07-05 18:11
0

<font color="green">Wtedy postanowiłem ściągnąć
kilka przykładów tego typu programów (kody
źródłowe) przeanalizowałem je dokładnie,
porównałem z moim programem i wszystko się
zgadzało, mam nawet kod źródłowy takiego
komunikatora z płyty pewnego czasopisma,
porównuje i nic wszystko poprawnie, ale co
najlepsze to kompiluje ten komunikator z
czasopisma (bez żadnej ingerencji w jego
kod źródłowy) i co się okazuje też nie działa!
To samo z kodami z Internetu między innymi z
tego serwisu. </span>

Sprawdź czy masz te same wersje komponentów..


Pozostało 580 znaków

2003-07-05 19:36
0

nie czytalem prawie ncizego tylko pcozatek: ale jezeli uzywasz tcp/ip sprawdz czy sie laczysz przez port inny niz "0" np. wybierz 1024

Pozostało 580 znaków

2003-07-06 10:38
0

Ale wyskakuje ci jakiś błąd jeśli tak to podaj numer błędu!


"Ten tylko nie popelnia bledow ,kto nic nie robi" - Theodore Roosvelt

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0