[html] dwa problemy

0

mam dwa pytanie

  1. zgodnie ze standardem XHTML 1.0 z znaczniku nie może znaleźć się atrybut border. Ale w przypadku gdy mam taki kod:

Kod:

  <a href="index.php?lang=en" class="link">
  <img src="gfx/english.gif" width="16" height="12" alt="Wersja angielska"/></a>
  <a href="index.php?lang=pl" class="link">
  <img src="gfx/polski.gif" width="16" height="12"  alt="Wersja polska"/></a>

Na stronie obrazek ma obramowanie chyba jak by miał border ustawiony na 5px. Jak rozwiążać ten problem.

  1. Drugie pytanie wrzucam swoją stronkę do validatora i otrzymuje następujące błędy. Czy mógłby mi ktoś pomóc je rozszyfrować??!!:

http://validator.w3.org/check[...]3A%2F%2Fimpreza.meohaw.net%2F

0
  1. style="border: 5px solid black"
  2. Przeczytaj może treść błędów? :-/
0

Przyda Ci się http://delta.lebkowski.info/p[...]3A%2F%2Fimpreza.meohaw.net%2F jeśli nie rozumiesz angielskich opisów błędów - trochę pisze po polsku.

Ogólnie:
Błedy 2-22 - źle powstawiane znaczniki (blokowe wewnątrz liniowych, albo bez opakowania bezpośrednio do body) - z tak pobieżnego przejrzenia Twojego kodu to o jakimś

zapomniałeś, bezpośrednio do <form> wstawiać tekstu nie można (a swoją drogą - radzę zapoznać się z marginesami na rzecz porzucenia nadmiernych   i znacznikiem Label zamiast tego co jest obecnie)
Bład 23 - atrybut target nie istnieje w XHTML 1.0 Strict (można się swobodnie pozbyć)
Błąd 24 - brakuje cudzysłowów (i tak dotyczy to atrybutu target, którego się należy pozbyć)
Błąd 25 - brakuje zamknięcia znacznika Img
Błąd 27 - atrybut language nie istnieje w XHTML 1.0 Strict (wystarczy samo type przy znaczniku Script)
Błąd 28 - patrz błąd 2
Błąd 29 - patrz błąd 25

A tak poza tym to fajnie, że chcesz od razu się do specyfikacji Strict stosować.

<?xml-stylesheet type="text/css" href="style/style.css" ?> 

możesz sobie odpuścić, i tak strona jest serwowana jako text/html, co do <?xml version="1.0" encoding="iso-8859-2" ?>


 to ja osobiście nie używam, bo Internet Explorer poniżej wersji 7 ma z nim problemy. Stosujesz też bardzo dużo &nbsp; i <br />, których niekoniecznie powinno się używać.
0

co do pierwszego to chyba chodzi o:

img { border: 0 }

0

Tutaj chodzi o obrazki jako linki i ja bym użył raczej:

a img { border: 0; }

;)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0