Strona spowodowała zbyt wiele przekierowań

0

Witam
Mam problem ze stroną na wordpress
Otóż niedawno zmieniałem adres z http na https, zrobiłem to ustawieniach głównych w wordpressie, zainstalowałem na serwerze ssl (let's encrypt) i w pliku .htaccess ustawiłem przekierowanie i wszystko działało ale ostatnio wchodzę na stronę i wyświetla się komunikat, że strona spowodowała zbyt wiele przekierowań, i w ogóle nie ma do niej dostępu. Próbowałem zmieniać coś w pliku .htaccess i strona się jakby naprawiła ale do pierwszego przeładowania i znowu to samo

Tak wygląda plik .htaccess

# BEGIN WordPress

<ifmodule mod_rewrite.c="mod_rewrite.c"> RewriteEngine On RewriteCond %{HTTPS} !=on RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule ^.*[-](\d+)/$ term/index\.php?id=$1&%{QUERY_STRING} [L] RewriteRule ^.*p/(.*)/$ term/index\.php?cat=$1&%{QUERY_STRING} [L] </ifmodule>

# END WordPress

Proszę o jakąś pomoc

0

Wykasuj to co zrobiłeś.
Zmień w ustawieniach strony wp z http na https.
Zainstaluj https://pl.wordpress.org/plugins/really-simple-ssl/
Włącz i tyle.

0
czysteskarpety napisał(a):

Wykasuj to co zrobiłeś.
Zmień w ustawieniach strony wp z http na https.
Zainstaluj https://pl.wordpress.org/plugins/really-simple-ssl/
Włącz i tyle.

Tylko jest taki problem, że nie mogę się zalogować do wordpresa i aktywować wtyczkę

0

Spróbuj coś takiego:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

z tym, że spróbuj na samym początku htaccess bez udziału modułów i wordpressa, nie wiem czy nie będzie problemów z mieszanym contentem (np. skrypty/fonty zewnętrzne po http) i wtedy i tak są błędy.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0