Nie znam się specjalnie na zależnościach frontowych, ale ile razy coś dodaję to dostaję taki komunikat:

npm WARN @babel/[email protected] requires a peer of @babel/[email protected]^7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @babel/[email protected] requires a peer of @babel/[email protected]^7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN [email protected] requires a peer of [email protected]^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN [email protected] requires a peer of @babel/[email protected]^7.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN [email protected] requires a peer of [email protected] - 3 but none is installed. You must install peer dependencies yourself.
npm WARN [email protected] requires a peer of [email protected]^1.14.7 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ [email protected]
added 68 packages in 23.249s

Pytania:

  • Tej zależności acorn-dynamic-import nawet nie mam w package.json, jakaś inna zależność musiała ją dodać.
  • Niby pisze że required a peer dependency, ale aplikacja jakoś działa bez nich. Mogę to zignorować i wrzucić na proda?
  • Nie rozumiem po co bootstrap'owi jest potrzebne jQuery? Ja chcę tylko bootstrapowe grid'y i formularze
  • fsevents jest potrzebne? Nie potrzebne?

Wolałbym zrobić tak zeby nie leciały żadne warningi (wiem też że czasem się tego nie da zrobić). Mogę je jakoś umniejszyć, poprawić coś? W załączniku package.json.


char mander; bool basaur;
Zaawansowana biblioteka T-Regx do wyrażeń regularnych w PHP