Czcionki, przeglądarki internetowe na Windows, tekst wyświetlanych z drobnymi różnicami

0

Tekst w tej samej czcionce na różnych przeglądarkach internetowych na Windows jest wyświetlana co do drobnych różnic różnie. Pytanie: jak zrobić by nie było tych różnic za pomocą CSS?

1

Mam pewne obawy, że zwyczajnie się nie da. Pół roku temu poprawiałem swój projekt bo wydawało mi się, że kolega od frontu się nie przyłożył. Niestety przyłożył. Większe problemy bywają na systemach. Font na Windows wyglądał prawie 1:1 jak z PSD, a na Linux już zupełnie inaczej, a wręcz fatalnie...

0

Na linuksie Debian Live KDE, na którym są takie same czcionki, na przeglądarce konqueror tekst jest podobny do tekstu wyświetlanego na Windows, a na Firefox na tym samym systemie jest wyświetlany małą czcionką tak jak by konqueror był lepszy do firefox.

0

1) nie ładuj systemowych fontów tylko dodawaj własne pliki woff lub woff2 do strony
2) firefox bodajże jako jedyna przeglądarka łapie ustawiania systemowe, zoom itp, więc jeśli w systemie zmniejszysz/powiększysz fonty to na firefoxe też się zwiększa lub pomniejszą
3) przeglądarki operta o webkita lub blinka, czyli wszystkie bazujące na chrome/safari rozmazują fonty i jest to strasznie wkurzające, tyle lat a jeszcze nie widziałem tak ostrych i wyraźnych fontów na chromopodobnych jak są na firefoxe.

0

I oczywiście nie da się tego wyłączyć za pomocą CSS?

0

It's Not a Bug, It's a Feature.

0

Spróbowałbym tego, ale to stary post:
https://stackoverflow.com/a/13911136/5305370
Edit: chociaż odpowiedź chyba z 2017 r.

0

Jeśli w systemie ustawimy więcej niż 100%, to przeglądarka na Windows widzi je jako 100%

0
mr_jaro napisał(a):

3) przeglądarki operta o webkita lub blinka, czyli wszystkie bazujące na chrome/safari rozmazują fonty i jest to strasznie wkurzające, tyle lat a jeszcze nie widziałem tak ostrych i wyraźnych fontów na chromopodobnych jak są na firefoxe.

No nie wiem. Jakiś rok temu FF z kolejną aktualizacją włączył mi wygładzanie (tfu!) rozmazywanie czcionek i jakieś dwie godziny szukałam, jak to cholerstwo w konfiguracji wyłączyć.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0