Instalacja Laravela na Debianie

0

Witam,
Zaktualizowałem PHP do 7.2 na moim serwerze i gdy próbuję teraz zainstalować najnowszą wersję Laravela(5.6) to część plików się pojawia a następnie otrzymuję taki błąd. Proszę o pomoc w wyjaśnieniu co należy poprawić, nic z tego nie rozumiem ;(

Do not run Composer as root/super user! See https://getcomposer.org/root for det    ails
Installing laravel/laravel (v5.6.12)
  - Installing laravel/laravel (v5.6.12): Loading from cache
Created project in /var/www/html/laravel
> @php -r "file_exists('.env') || copy('.env.example', '.env');"
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - phpunit/phpunit 7.1.x-dev requires ext-dom * -> the requested PHP extensio    n dom is missing from your system.
    - phpunit/phpunit 7.0.x-dev requires ext-dom * -> the requested PHP extensio    n dom is missing from your system.
    - phpunit/phpunit 7.0.3 requires ext-dom * -> the requested PHP extension do    m is missing from your system.
    - phpunit/phpunit 7.0.2 requires ext-dom * -> the requested PHP extension do    m is missing from your system.
    - phpunit/phpunit 7.0.1 requires ext-dom * -> the requested PHP extension do    m is missing from your system.
    - phpunit/phpunit 7.0.0 requires ext-dom * -> the requested PHP extension do    m is missing from your system.
    - Installation request for phpunit/phpunit ^7.0 -> satisfiable by phpunit/ph    punit[7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.x-dev, 7.1.x-dev].

  To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php/7.2/cli/php.ini
    - /etc/php/7.2/cli/conf.d/10-opcache.ini
    - /etc/php/7.2/cli/conf.d/10-pdo.ini
    - /etc/php/7.2/cli/conf.d/20-calendar.ini
    - /etc/php/7.2/cli/conf.d/20-ctype.ini
    - /etc/php/7.2/cli/conf.d/20-exif.ini
    - /etc/php/7.2/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.2/cli/conf.d/20-ftp.ini
    - /etc/php/7.2/cli/conf.d/20-gd.ini
    - /etc/php/7.2/cli/conf.d/20-gettext.ini
    - /etc/php/7.2/cli/conf.d/20-iconv.ini
    - /etc/php/7.2/cli/conf.d/20-json.ini
    - /etc/php/7.2/cli/conf.d/20-mbstring.ini
    - /etc/php/7.2/cli/conf.d/20-phar.ini
    - /etc/php/7.2/cli/conf.d/20-posix.ini
    - /etc/php/7.2/cli/conf.d/20-readline.ini
    - /etc/php/7.2/cli/conf.d/20-shmop.ini
    - /etc/php/7.2/cli/conf.d/20-sockets.ini
    - /etc/php/7.2/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.2/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.2/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.2/cli/conf.d/20-tokenizer.ini
  You can also run `php --ini` inside terminal to see which files are used by PH    P in CLI mode.
1

Komunikat jest dosyć jasny:

(...) requires ext-dom * -> the requested PHP extension (...) is missing from your system.

0

W takim razie jak zainstalować PHP 7.2, który jest wymagany przez Laravela 5.6 żeby jednocześnie zachować pliki z PHP 7.0?

0

Przeczytaj komunikat raz jeszcze, uważnie.
Mówi on You have an invalid PHP version installed czy You are missing an extension?

2

nie skonfigurowałeś php.ini i tyle w temacie

0

Teraz to już w ogóle napsułem na tym serwerze... :D Można Debiana przywrócić do stanu ''fabrycznego'' z poziomu cmd? Lub skasować composera i php aby móc to zainstalować na nowo i poprawnie?

1
apt install php7.1-xml
1

Ok, raczej 7.2 bo taką masz wersje php jak się zdaje

0

Skasowałem Composera oraz PHP abyzrobić wszystko od nowa i tym razem mam błąd przy instalacji PHP :(

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.2-cli : Depends: php7.2-opcache but it is not going to be installed
              Depends: libc6 (>= 2.27) but 2.24-11+deb9u3 is to be installed
              Depends: libsodium23 (>= 1.0.14) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ktoś? Coś? :( Można w jakiś sposób wyczyścić ten serwer z wszelkich zainstalowanych rzeczy?

1

a potrafisz czytać te błędy? bo mam wrażenie, że nie. Przecież wyraźnie napisał, że brakuje mu bibliotek które musisz doinstalować.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0