Dziwny input

Odpowiedz Nowy wątek
2015-03-13 22:43
0

Witam,
zrobiłem inputa w html i po najechaniu na niego ma pojawiać się box-shadow. Input ma obrazkowe tło. wszytko super, problem w tym, że po załadowaniu strony postanawia on sobie "wjechać" na nią co nie było planowane.

#in{
    transition: 1s all;
    -webkit-transition: 1s all;
    -moz-transition: 1s all;

    height: 30px;
    margin-left: 190px;
    width: 220px;
    background-color: black;
    color: white;
    background-image: url('in.png');
    background-position: 92px -32px;
    background-repeat: no-repeat;
    text-align: center;
    border: 2px solid grey;
    border-radius: 15px;
}

#in:focus {
    outline: none;

}

#in:hover{
    transition: 1s all;
    -webkit-transition: 1s all;
    -moz-transition: 1s all;
    -webkit-box-shadow: 10px 10px 65px #6b0000;
}
<form action="fear.php" method="get">
                <input type="text" name="value" id="in" placeholder=" Number" /> 
            </form>

Pozostało 580 znaków

2015-03-14 00:06
0

http://jsbin.com/tanizenoyi/1/edit
nie widzę tu nic dziwnego.
możesz jasno opisać o co Ci chodzi?


Pozostało 580 znaków

2015-03-14 12:54
0

Po załadowaniu strony input ma margin-left 0px. Wjeżdża w określonym przeze mnie czasie na swoje miejsce (ustalony margin-left). Do tego kolor tła przechodzi z białego na czarny oraz przemieszcza się obrazek tła.

Pozostało 580 znaków

2015-03-14 14:53
1

Z kodu nic takiego nie wynika.
BTW: Czego stosujesz -webkit-box-shadow, co zadziała tylko na przeglądarkach na webkicie, zamiast po prostu box-shadow, co zadziała wszędzie?


Pozostało 580 znaków

2015-03-14 22:41
0

Zmieniłem margin na position: relative; Input na początku się nie rusza tylko zmienia kolor tła. Problem występuje tylko na Chromie. Z -webkit-'em racja ;)

Rozwiązałem. Problem zniknął kiedy dodałem w headzie sekcję <scrpit>. Nie wiem jak to się ma do css, ale strona działa, tak jak miała i to się liczy ;).

edytowany 1x, ostatnio: Ehlert, 2015-03-14 22:58

Pozostało 580 znaków

2015-03-15 00:25
1

@Ehlert: Twój opis brzmi tak magicznie (powtarzam: z kodu, który dałeś, ABSOLUTNIE NIE WYNIKA takie działanie, jakie opisujesz), że jest duża szansa, że to działa:
a) tymczasowo
b) tylko na określonych przeglądarkach
c) tylko w określonych warunkach

Jakbyś wracał na forum z tym samym problemem, to nie zapomnij wrzucić większej ilości kodu, a najlepiej podać linka do problematycznej strony.


Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0