Fonty na firefox nie działają

0

Witam serdecznie :)
Pewnie temat mielony, ale szukam i tak zbytnio rozwiązania nie mogę znaleźć także może ktoś ma coś oryginalnego.

Fonty działają na wszystkich przeglądarkach poza firefoxem. W ustawieniach mam zaznaczoną opcję, aby przeglądarka ładowała inne fonty. Co więcej zauważyłem, że działa font, który ma przypisany font-weight:bold, pozostałe nie. Na czym może polegać problem, jak się z tym uporać?
Kod:

@CHARSET "UTF-8";

@font-face {
    font-family: 'Roboto';
    src: url('fonts/Aller_Std_Rg.eot') format('eot'), 
        url('fonts/Aller_Std_Rg.woff') format('woff'),
        url('fonts/Aller_Std_Rg.otf') format('opentype'),    
        url('fonts/Aller_Std_Rg.ttf') format('truetype');
    font-weight: normal;
    font-style: normal;

}
@font-face {
    font-family: 'Roboto';
    src: url('fonts/Aller_Std_Ltlt.eot') format('eot'), 
        url('fonts/Aller_Std_Ltlt.woff') format('woff'),  
        url('fonts/Aller_Std_Ltlt.otf') format('opentype'),
        url('fonts/Aller_Std_Ltlt.ttf') format('truetype');
    font-weight: lighter;
    font-style: normal;

}
@font-face {
    font-family: 'Roboto';
    src: url('fonts/Aller_Std_Bd.eot') format('eot'), 
        url('fonts/Aller_Std_Bd.woff') format('woff'),  
        url('fonts/Aller_Std_Bd.otf') format('opentype'),
        url('fonts/Aller_Std_Bd.ttf') format('truetype');
    font-weight: bold;
    font-style: normal;

}

Pozdrawiam

EDIT=================================================

Rozwiązaniem jest zmienienie w każdej wersji czcionki font-family na inną nazwę. Dość uporczywe bo teraz wszędzie tam gdzie miałem bold czy lighter będę musiał zmienić font-family. Mozilla dziwnie to interpretuje.

EDIT2=================================================

Najlepszym rozwiązaniem jest link w poście poniżej od @dzek69 .

1

Pewnie FF nie ogarnia jeszcze ładowania fontów o tej samej nazwie, a różnych stylach.

Kiedyś była spora rozrzutność w interpretacji @font-face i zawsze najbezpieczniejszą opcją było fonta z boldem nazywać inaczej, np. RobotoBold, co oczywiście było mocno niewygodne.

Po chwili:
http://stackoverflow.com/ques[...]ght-from-my-font-face-options
Tu masz rozwiązanie w ostatnim poście ;) Dokładnie ten sam błąd.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0