tło na stronie nie jest dopasowywane do wielkości okna przeglądarki

0

Hej,
mam zdjęcie wstawione jako background, załóżmy że ma wymiary 1020x720 czy coś takiego. I teraz jak odpalam to Visual Studio i podgląd strony to niby wyświetla się poprawnie. Ale:
-na telefonie mam to zdjęcie o wymiarach powiedzmy 50x100 i powielone w 2 kolumnach po 7 rzędów (czyli 14 małych obrazeczków),
-jak załaduje to na serwer (azure microsoft) i odpale to np. w Chrome to ucina mi jakieś 100px od spodu i 100px od góry.

Na razie pomijając telefony, jak mogę to ogarnąć żeby dobrze wyglądało po załadowaniu na serwer ?
jestem totalnie zielony jeśli chodzi o jakieś css itd.

0

Pokaż jakiś kod strony, jakieś css itp. Na sucho mogę tylko podpowiedzieć że masz coś zrabane w okolicach kodu strony albo szablonu.

0

Mam dwa jakieś pliki w projekcie visual-a. W site.css wstawiłem to zdjęcie w kodzie body i teraz tak to wygląda:

body {
    padding-top: 50px;
    padding-bottom: 20px;
    background-image: url(tlo.jpg);
    background-size: cover;
    width: 90%;
    margin: auto;
    min-width: 600px;
    max-width: 2000px
}

no i do tego cały plik bootstrap.css

i też tutaj pytanie do magików CSS, jak powinienem przygotować np. tło które ma być przyciskiem? albo tło na strone? jakich wymiarów to powinno być?

0

hmm....

html { 
  background: url(tlo.jpg) no-repeat center center fixed; 
  -webkit-background-size: cover;
  -moz-background-size: cover;
  -o-background-size: cover;
  background-size: cover;
}

Powinno +/- załatwić sprawę.

0

Sprawdziłem te rady, niestety nie działa to dalej :/

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0