blokada .htaccess

0

Witam

Dlaczego jak mam stworzyny pli .htaccess w katalogu na serwerze a w nim

<Files ~"/.txt$">
Order allow,deny
Deny from all
</Files>

To mimo wszystko po wpisaniu www.strona.pl/proba.txt zostaje wyświetlona zawartość pliku ??
Nie wiem jak zabezpieczyć aby nie było można podglądać plików

proszę o pomoc

0

<Files ~"/.txt$"> - mam wrażenie, że tu masz coś źle, ale nie mam pewności - upewnij się z manualem.

Nie wiem jak zabezpieczyć aby nie było można podglądać plików

najłatwiej wrzucić tam pusty plik html.

0

id02009 już właśnie doczytałem z tym wrzuceniem pustego pliku

poszukam manualu z tym, że na każdej stronie właśnie był taki zapis <Files ~"/.txt$">

sprawdzałem to też wstawiając jpg.. też nie działało

0

Podejrzewam, że powinno tam znaleźć się wyrażenie regularne.
Czyli: <Files ".*.txt$"> ...

Spróbuj. A jak nie będzie działać, to zajrzyj do manuala ;)

0

nie działa

zaglądałem do manuala i jest tam pokazane tak jak zrobiłem to w 1 poście

0

Właśnie doczytałem, że nie chodzi Ci o zablokowanie listowania katalogu, więc ten pusty index.html -to nieważne.
Może Ci nie działać, bo w konfigu serwera jest ustawione, że nie możesz nadpisywać Allo czy deny, sprawdź w manualu coś o AllowOverride, np:
<Directory "/srv/www/htdocs">
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named explicitly --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs-2.2/mod/core.html#options
# for more information.
Options All
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
AllowOverride All
# Controls who can get stuff from this server.
Order allow,deny
Allow from all
</directory>

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0