kodowanie(utf-8 itd.)

Odpowiedz Nowy wątek
jaaaaaa
2007-01-18 18:00
jaaaaaa
0

mam problem z kodowaniem znaków na stronie, nie wyswietla mi polskich znaków.. a kombinowalem juz niesamowicie.. załozmy ze mam taką stronę:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="pl" lang="pl">
<head>
<meta http-equiv="Content-Language" content="pl" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
</head>
<body>
śśśłłłęę
</body>
</html>

niby jest wszystko poprawnie(tak jak na innych stronach, np na tej :P) a jednak polskich znakow nie wyswietla i nie mam pojecia dlaczego.. a jak zastosuje ISO-8859-2 to cześć znakow mi wysiwetla ale nie wszystkie ;(

dodam jeszcze ze nagłowek próbowałem tez wysyłac przpez php (header('Content-type: text/html; charset=utf-8')i dochodzi do przeglądarki bo sprawdzałem we wtyczce do ff (live http headers) lecz nic to nie zmienia

Pozostało 580 znaków

nav
2007-01-18 18:46
nav

Rejestracja: 16 lat temu

Ostatnio: 2 lata temu

Lokalizacja: Warszawa

0

Pytanie, czy plik też jest zapisany w tym kodowaniu? Ja nigdy nie miałem z tym problemów, pod warunkiem że w edytorze ustawiłem kodowanie na utf.


utf-8 rlz! ٩(ಥ_ಥ)۶

Pozostało 580 znaków

jaaaaaaaaaaa
2007-01-18 19:13
jaaaaaaaaaaa
0

nodobra z tym juz sobie poradziłem(uzyłem funkcji iconv z php).. ale teraz przy pobieraniu znaków z bazy mysql mam ten sam problem, odrazu mówie:

  • baza ma ustawione kodowanie na utf8_unicode (przynajmniej tak "mówi" phpmyadmin)
  • phpmyadmin pobiera dane bez problemu i wyswietla je prawidłowo
  • funkcja iconv w tym wypadku nie pomaga ;(

Pozostało 580 znaków

2007-05-16 22:09

Rejestracja: 12 lat temu

Ostatnio: 12 lat temu

0

Zmień kodowanie na windows-1250.


Risk your life

Pozostało 580 znaków

2007-05-16 22:15

Rejestracja: 16 lat temu

Ostatnio: 9 lat temu

0

Jeśli phpMyAdmin wyświetla prawidłowe kodowanie, to znaczy, że dane w bazie wcale nie są zapisane w utf-8 :).


Grunt to uziemienie...

Pozostało 580 znaków

2007-05-16 23:48

Rejestracja: 17 lat temu

Ostatnio: 8 miesięcy temu

0

możesz też użyć mojej funkcjy my_iconv (zmodyfikowana wersja, co na 4p była) - pare razy na forum wrzucałem ;). Wprawdzie nie jest to eleganckie rozwiązanie, ale co brut to brut :D. Ważne, że działa...

o masz nawet link do pastebina:
http://pastebin.4programmers.net/1485


Pozostało 580 znaków

Odpowiedz

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0