Problem z PyCharm

0

Witam,

Ostatnio zmieniłem laptopa, na starym wszystko działało jak należy, natomiast na nowym po zainstalowaniu PyCharma pojawia mi się taki komunikat po uruchomieniu najprostszego programu.

C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\python.exe C:/Users/WIN7/PycharmProjects/LifestyleVita/venv/Main.py
[INFO   ] [Logger      ] Record log in C:\Users\WIN7\.kivy\logs\kivy_18-02-04_3.txt
[INFO   ] [Kivy        ] v1.10.0
[INFO   ] [Python      ] v3.6.4 (v3.6.4:d48eceb, Dec 19 2017, 06:04:45) [MSC v.1900 32 bit (Intel)]
[INFO   ] [Factory     ] 194 symbols loaded
[INFO   ] [Image       ] Providers: img_tex, img_dds, img_gif (img_sdl2, img_pil, img_ffpyplayer ignored)
[CRITICAL] [Text        ] Unable to find any valuable Text provider.
sdl2 - ImportError: DLL load failed: Nie można odnaleźć określonego modułu.
  File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\core\__init__.py", line 59, in core_select_lib
    fromlist=[modulename], level=0)
  File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\core\text\text_sdl2.py", line 12, in <module>
    from kivy.core.text._text_sdl2 import (_SurfaceContainer, _get_extents,

pil - ModuleNotFoundError: No module named 'PIL'
  File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\core\__init__.py", line 59, in core_select_lib
    fromlist=[modulename], level=0)
  File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\core\text\text_pil.py", line 7, in <module>
    from PIL import Image, ImageFont, ImageDraw

[CRITICAL] [App         ] Unable to get a Text provider, abort.

Process finished with exit code 1

Main.py

import kivy
kivy.require('1.10.0')

from kivy.app import App
from kivy.uix.button import Button

class TestApp(App):

    def build(self):
        # return a Button() as a root widget
        return Button(text='hello world')

if __name__ == '__main__':
    TestApp().run()

Main.kv

#:kivy 1.10.0

Button:
    text: 'Hello from test.kv'

Czy coś źle zainstalowałem? Mam na myśli kivy lub pythona.

0

Zainstalowałem PIL, teraz nie może znaleźć Window provider. Mam zainstalowane wszystkie zalecane moduły. Nie mam pojęcia co jeszcze mogę zainstalować. Sprawdziłem jeszcze na starym laptopie, na którym to działa. Nie ma tam zainstalowanego tam żadnego modułu, którego bym nie miał na nowym.

"""
[INFO ] [Logger ] Record log in C:\Users\WIN7.kivy\logs\kivy_18-02-10_44.txt
[INFO ] [Kivy ] v1.10.0
[INFO ] [Python ] v3.6.4 (v3.6.4:d48eceb, Dec 19 2017, 06:04:45) [MSC v.1900 32 bit (Intel)]
[INFO ] [Factory ] 194 symbols loaded
[INFO ] [Image ] Providers: img_tex, img_dds, img_pil, img_gif (img_sdl2, img_ffpyplayer ignored)
[INFO ] [Text ] Provider: pil(['text_sdl2'] ignored)
[CRITICAL] [Window ] Unable to find any valuable Window provider.
sdl2 - ImportError: DLL load failed: Nie można odnaleźć określonego modułu.
File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\core__init__.py", line 59, in core_select_lib
fromlist=[modulename], level=0)
File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\core\window\window_sdl2.py", line 26, in <module>
from kivy.core.window._window_sdl2 import _WindowSDL2Storage

[CRITICAL] [App ] Unable to get a Window, abort.
Exception ignored in: 'kivy.properties.dpi2px'
Traceback (most recent call last):
File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\utils.py", line 496, in get
retval = self.func(inst)
File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\metrics.py", line 174, in dpi
EventLoop.ensure_window()
File "C:\Users\WIN7\AppData\Local\Programs\Python\Python36-32\lib\site-packages\kivy\base.py", line 127, in ensure_window
sys.exit(1)
SystemExit: 1
[CRITICAL] [App ] Unable to get a Window, abort.

Process finished with exit code 1

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0