[PHP] i blad flash'a

0

Witam.
Mam pytanko. Na prywatnym komputerze z Apache'em i MySQL probuje uruchomic stworzony plik swf.

Gdy uzyje kodu w HTML'u

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
 WIDTH=550 HEIGHT=400>
 <PARAM NAME=movie VALUE="Movie3.swf"> <PARAM NAME=quality VALUE=high> <PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="movie.swf" quality=high bgcolor=#FFFFFF  WIDTH=550 HEIGHT=400 TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED>
</OBJECT>

wszystko dziala i flash sie laduje odtwarza itp.

natomiast jak stworze pusty plik *.php i wpisze do niego

<?
  ..tutaj kod od flasha ale ze zamienionymi " na \"
?>

to flash juz nie chce sie zaladowac..

Ktos ma pomysl dlaczego?

0

a wygenerowany kod HTML przez parser php jest taki sam jak ten napisany powyżej ?

0

a robisz to w echo? :]

0

No pewnie ze robie to w echo :D, ale tak jak pisze powyzej - nie dziala..

0

Ktos ma pomysl dlaczego?

Ja mam pomysł: dlatego bo cos popsułeś :P

A co popsułeś to Ty powinieneś wiedzieć najlepiej bo Ty dysponujesz niepoprawnym kodem, nam wkleiłeś ten działający i tylko się cenne bajty zmarnowały...

0

Niczego nie popsulem. Skoro kod dziala bez PHP to jest prawidlowy.
PHP nie wyrzuca nieprawidlowych znakow i wyswietla strone prawidlowo, robiac nawet miejsce na animacje o okreslonym rozmiarze. Ale animacja nigdy sie juz nie pojawia.

0

a nie możesz po prostu pokazać tego kodu w php ? :|

0

W przegladarkach jest cos takiego jak "Pokaz zrodlo dokumentu". Podejrzyj zrodlo i zobacz, czy kod wyprodukowany przez PHP jest taki jakiego oczekujesz. I juz. Na pewno musi byc jakas roznica.

0

Sprawdz wielkosc liter, i czy flashka jest w tym samym folderze (znaczy sciezke ;] )

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0