[php] Upload - problem

0

Mam problem z uploadem plików.
Zrobiłem tak jak w tym kazał gość z tego tematu:
http://4programmers.net/Forum/viewtopic.php?id=57310
Ale jak robię tak na localhocie to nic nie działa ( nie ma nigdzie wybranego pliku!!)

Help [!!!]

0

Ale jak robię tak na localhocie to nic nie działa ( nie ma nigdzie wybranego pliku!!)

co to ma byc ? to jest opis problemu ? nic nie dziala nie ma pliku ?
rownie dobrze mozesz nie miec PHP na localhoscie...

0

Nigdzie nie ma skopiowanego pliku!!

0

Nigdzie nie ma skopiowanego pliku!!

wykonaj nastepujace czynnosci aby okreslic swoj problem:

  1. Wykonaj echo $_FILES["userfile"]["tmp_name"] - dzieki temu bedziesz wiedzial czy przeslal sie jakis plik, mozesz tez te zmienna wstawic do funkcji is_uploaded_file() w tedy bedziesz mial absolutna pewnosc ze plik sie poprawnie wyslal...

  2. Uzyj funkcji move_uploaded_file(), upewnij sie czy sciezka ktora podales w 2 argumencie na pewno istnieje...

  3. Sprawdz co zwrocila funkcja move_uploaded_file() przy pomocy if...

  4. Sprawdz czy nie masz mokrej pieluszki...

  5. Jezeli pojawiaja sie jakies bledy to powiec o nich, w ogole mogl bys powiedziec co ci sie pojawia na ekranie, czy na pewno masz wlaczony monitor ?

  6. Wywal z formularza input MAX_FILE_SIZE value="0", u mnie to nie ma znaczenia ale dla pewnosci testow lepiej usun cos co moglo by wplynac na ich wynik...

0

Dobra wywaliłem MAX_FILE_SIZE value=\"0\" i działa

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0