Composer PHP Fatal error

Odpowiedz Nowy wątek
2019-06-19 17:17
0

Witam podczas instalacji biblioteki użytkowników FOSUserBundle w Symfony Composer wywala mi poniższy błąd:

Updating dependencies (including require-dev)
PHP Fatal error:  Out of memory (allocated 1608515584) (tried to allocate 268435456 bytes) in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/src/Composer/DependencyResolver/Solver.php on line 220

Fatal error: Out of memory (allocated 1608515584) (tried to allocate 268435456 bytes) in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/src/Composer/DependencyResolver/Solver.php on line 220

Co może byc przyczyną i jak mogę zaisntalowac ta biblioteke? Grzebałem w php.ini zmieniałem limity ale nic nie pomogło. Bardzo proszę o pomoc

zależy jeszcze od wersji symfony, sprawdź link: https://www.google.pl/search?[...]..0..0i131j0j0i10.B_HHRjEGqTc - ccwrc 2019-06-19 17:25
Wersja Symfony 3.3 niestety googlowałem i jak na razie żadna z odp nie działa. Może ktoś miał podobny problem? - Łapa_krk 2019-06-19 17:53

Pozostało 580 znaków

2019-06-19 18:11
0

A sprawdzałes czy dobry plik .ini edytowales?
Robiłeś composer self-update? (z głowy pisze, wiec może polecenie jest ciutke inne)

edytowany 1x, ostatnio: axelbest, 2019-06-19 18:13

Pozostało 580 znaków

2019-06-19 18:20
0

eee? przecież on próbuje ledwo 32MB zaalokować. Jak robisz limity na 32MB to się nie dziw, że się wysypuje. U mnie testy potrafią zjeść ponad 100MB. Daj mu limit na 256MB i przejdzie.

edytowany 2x, ostatnio: mr_jaro, 2019-06-19 18:23
1608515584 bytes /1024 = 1 570 816 KB / 1024 = 1534 MB. Skąd wam wyszło z tego komunikatu 32MB? Druga wartość mi wychodzi jako 256MB - axelbest 2019-06-19 18:30
@axelbest: no fakt, podzieliłem jeszcze przez 8 - mr_jaro 2019-06-19 18:32
Uff... Juz myślałem, ze to mi się już coś w głowie zaczyna ..ebac :) - axelbest 2019-06-19 18:41

Pozostało 580 znaków

2019-06-19 18:23
0

W pliku php.ini, memory_limit daj na -1 i sprawdź czy przypadkiem nie masz przepełnionego dysku bo może limit ustawiasz dobrze a pamięci nie masz ;)

Pozostało 580 znaków

2019-06-19 18:24
0
tomanhez napisał(a):

W pliku php.ini, memory_limit daj na -1 i sprawdź czy przypadkiem nie masz przepełnionego dysku bo może limit ustawiasz dobrze a pamięci nie masz ;)

Przecież widzisz błąd, ma limit na 32 a próbuje zaalokować ~200MB

Pozostało 580 znaków

2019-06-19 18:58
0

na dysku twardym mam wolne 28 GB
zmieniłem memory_limit w php.int na -1 niestety nadal ten sam problem. Wcześniej było ustawione 128 M zmienialem na większe wartości niestety nie pomogło...

Pozostało 580 znaków

2019-06-19 19:05
0

Mam wrażenie że to może być wina Composera. Spróbuj dwie rzeczy zrob, composer self-update i wtedy instaluj bundla, jak to nie pomoże to cofnij się do jakiejś starszej wersji Composera i wtedy spróbuj (łącznie test powinien być przeprowadzony na 3 wersjach Composera - obecnej, nowszej i starszej). Słyszałem że symfony + composer w jakiejś wersji nie lubią sie

BTW https://github.com/composer/c[...]s/5345#issuecomment-219641008

edytowany 1x, ostatnio: axelbest, 2019-06-19 19:10

Pozostało 580 znaków

2019-06-19 19:17
0

https://getcomposer.org/doc/a[...]ooting.md#memory-limit-errors
Zawsze warto też sprawdzić czy aby na pewno nie masz kilku wersji PHP i composer nie korzysta z innej wersji PHP niż projekt.

edytowany 1x, ostatnio: jurek1980, 2019-06-19 19:25
jak mogę sprawdzić ile mam wersji PHP ? Po wpisaniu w konsoli PHP -V pokazuje mi 5.3.1 jak sprawdzić czy mam jeszcze inne ? - Łapa_krk 2019-06-19 23:52

Pozostało 580 znaków

2019-06-19 23:45
0

niestety po wpisaniu komendy composer self-update dalej przy instalacji te biblioteki pojawia mi sie:

PHP Fatal error:  Allowed memory size of 1610612736 bytes exhausted (tried to allocate 24 bytes) in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/vendor/composer/semver/src/Constraint/Constraint.php on line 153

Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 24 bytes) in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/vendor/composer/semver/src/Constraint/Constraint.php on line 153

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.

Pamięć na dysku mam , RAM też (8GB ) co może być przyczyną ?

Pozostało 580 znaków

2019-06-19 23:53
0

ruszałeś coś ostatnio z ustawieniami? musiało się coś stać, takie rzeczy nie dzieją się od tak.

ciężko powiedzieć raczej chyba nieostatnio troche walczyłem z Gitem w konsoli może przez to coś wywaliło? Ale nie powinno - Łapa_krk 2019-06-20 00:02
bardziej sie zastanawiam ze moge miec rożne wersje PHP zainstalowane i kilka plików php.ini ale głowny jest w Xampp - Łapa_krk 2019-06-20 00:03

Pozostało 580 znaków

2019-06-20 00:00
0

co sie okazuje mam tez dwa pliki php.ini jeden w XAMPP gdzie chyba z niego korzysta Composer? a drugi a katalogu mojego projektu symfony ale w tym pliku (drugim) jest tylko tyle:

extension="mongo.so"
extension="memcache.so"
extension="memcached.so"
extension="redis.so"

apc.enabled=1
apc.enable_cli=1
edytowany 1x, ostatnio: Łapa_krk, 2019-06-20 00:01

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0