jak zainstalowac laravelcollections ?

Odpowiedz Nowy wątek
2018-08-14 09:45
0

Witam

Probuje doinstalowac nastepujace zaleznosci "laravelcollective/annotations" poprzez plik composer.json i nastepnie wykonanie composer update i dostaje komunikat ze nie ma nic do zaktualizowania

"require": {
"laravelcollective/annotations": "5.4.*"
}
albo probuje poprzez polecenie composer require doinstalowac wspomnianie zaleznosci i otrzymuje ponizsze komunikaty

php composer.phar require "laravelcollective/annotations": "5.4.*"

lub

php composer.phar require "laravelcollective/html": "5.4.*"

i komunikaty

Root package 'laravelcollective/annotations' cannot require itself in its composer.json
Did you accidentally name your root package after an external package?

Co jest nie tak ?

Pozostało 580 znaków

2018-08-14 09:48
0

Wrzuć swój cały composer.json.


Pozostało 580 znaków

2018-08-14 10:05
0
{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=7.0.0",
        "fideloper/proxy": "~3.3",
        "laravel/framework": "5.5.*",
        "laravel/tinker": "~1.0"

    },  
    "require-dev": {
        "filp/whoops": "~2.0",
        "fzaninotto/faker": "~1.4",
        "mockery/mockery": "~1.0",
        "phpunit/phpunit": "~6.0",
        "symfony/thanks": "^1.0"
    },
    "autoload": {
        "classmap": [
            "database/seeds",
            "database/factories"
        ],
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "extra": {
        "laravel": {
            "dont-discover": [
            ]
        }
    },
    "scripts": {
        "post-root-package-install": [
            "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "@php artisan key:generate"
        ],
        "post-autoload-dump": [
            "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
            "@php artisan package:discover"
        ]
    },
    "config": {
        "preferred-install": "dist",
        "sort-packages": true,
        "optimize-autoloader": true
    }
}
edytowany 1x, ostatnio: Patryk27, 2018-08-14 10:12
Pamiętaj o umieszczaniu kodu w odpowiednich znacznikach. - Patryk27 2018-08-14 10:12

Pozostało 580 znaków

2018-08-14 10:13
0

Co konkretnie wpisujesz do linii komend?


Pozostało 580 znaków

2018-08-14 10:18
0

obydwie wersje ponizsze , lub przez dodanie lini do composer.json do sekcji require "laravelcollective/annotations": "5.4.*" i nastepnie wykonanie polecenia php composer.phar udpate
i

php composer.phar require "laravelcollective/annotations": "5.4.*"

lub

php composer.phar require "laravelcollective/html": "5.4.*"

Pozostało 580 znaków

2018-08-14 10:21

Pierwsze primo: php composer.phar require laravelcollective/html:5.4.* - bez spacji po dwukropku, cudzysłowy także są zbędne.

Drugie primo: dlaczego ograniczasz wersję do 5.4.*?


Pozostało 580 znaków

2018-08-14 10:23
0

taka opcje tez sprawdzalem i komunikaty takie jak wczesniej :) . Jesli chodzi o wersje to myslalem ze ta jest najswiezsza , ze innej nie ma , tak sugeruja w dokumentacji

Pozostało 580 znaków

2018-08-14 10:31
0

tak sugeruja w dokumentacji

Gdzie tak sugerują?

W ich oficjalnej dokumentacji nie ma wcale napisane 5.4 is the newest version available ;-)


Tak czy siak - najświeższą jest wersja 5.6 (patrz: https://github.com/LaravelCollective/annotations) - zgodnie z numeracją samego Laravela.

Z racji, że Ty działasz na Laraverze 5.5 (zgodnie z tym, co masz w composer.json), powinieneś też taką wersję zainstalować:

php composer.phar require laravelcollective/annotations:5.5.*

Pamiętaj - nie przeklejaj komend z internetu na pałę, tylko bądź świadom sposobu w jaki działają.


edytowany 1x, ostatnio: Patryk27, 2018-08-14 10:31

Pozostało 580 znaków

2018-08-14 10:34
0

z najnowsza wersja jest tak samo jak z poprzednimi :)

Pozostało 580 znaków

2018-08-14 10:34
0

Co to znaczy z najnowszą wersją?
Co wpisujesz w konsoli?


edytowany 1x, ostatnio: Patryk27, 2018-08-14 10:34

Pozostało 580 znaków

2018-08-14 10:39
0

wpisalem

php composer.phar require laravelcollective/html:5.5.*

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0