instalacja PHP 5.3, 5.4, 5.5, 5.6

0

Witam

Mam zainstalowanego Apache 2.2.16 razem z PHP 5.2.14 i od pewnego dluzszego czasu chce przeskoczyc na nowa wersje najlepiej 5.6 ale nie chodzi mi, wszystkie poprzednie tez sprawiaja problem po prostu po podmienieniu katalogu z "PHP" apache nie startuje nie podam w tej chwili logow bo testowalem to w zeszlym tygodniu i stracilem je zastanowilo mnie za to taki dopisek na stronie php.net a mianowice przy wersji podaja taki skrot VC9 lub VC11 czy trzeba doinstalowywac Visual C? aktualnie mam windows xp+sp3 do wersji 5.2 i wczesniejszych nie trzeba bylo nic takowego doinstalowywac wiec tak troche mnie to zdziwilo

0

Nie wiem w sumie jak to z tymi VC++ Redist, ale chyba instalacja jednego wystarcza: http://www.microsoft.com/en-us/download/details.aspx?id=30679

Jeżeli będziesz miał wybór pomiędzy Thread-Safe a Non-Thread-Safe to zainstaluj ten pierwszy.

0

Informacja o VC służy do dobrania PHP pod kątem Apache'a. Wersja PHP VC11 nie będzie działać z apachem skompilowanym w VC9. Takowego apache'a możesz skompilować sam albo pójść na łatwiznę i ściągnąć z apachelounge: http://www.apachelounge.com/download/

Co do NTS i TS to tam jest notka na stronie pobierania paczki z php:

IIS

If you are using PHP as FastCGI with IIS you should use the Non-Thread Safe (NTS) versions of PHP.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0