Problem ze skonfigurowaniem virtulanego host przez xampp pod Zend Framework

Odpowiedz Nowy wątek
2012-10-02 23:13
0

Więc tak, zaczynam od dodania zmiennej środowiskowej. Poźniej php.ini dodaje include_path, dalej httpd.conf i httpd-vhosts.conf, hosts.conf etc wszystko w dokumentacji ZF. Wcześniej to działało bez problemu, ale ściągnąłem najnowszego xampp'a i jest problem:

Zabroniony dostęp!

Nie masz prawa dostępu do żądanego katalogu. W katalogu nie ma indeksu lub katalog jest zabezpieczony przed odczytem.

Jeśli myślisz, że jest to błąd tego serwera, skontaktuj się z administratorem.

Error 403

Wie ktoś skąd takie coś??

Pozostało 580 znaków

2012-10-02 23:20
0

Może podaj dokładną konfigurację? (tj. żeby była jasność - wylistuj wszystkie pliki konfiguracyjne), powiedz też którą domenę próbujesz otworzyć.


Pozostało 580 znaków

2012-10-03 12:58
0

Linki z kodem z plików conf:
-xampp'a mam na C:\
-bibliotekę z Zend Framework na C:\xampp\htdocs\zf\
(podkatalogi w folderze zf to oczywiście nic innego jak bin oraz library
-adres pożądanego virtualnego hosta to zend/ lub www.zend
-miejsce projektu zend: C:\Zend <-pod tym adresem są wszystkie śmiecli, application, public .zfproject etc

(0)windows/drivers/etc/hosts
http://codetidy.com/3684/
(1)httpd-vhost.conf
http://codetidy.com/3685/
(2)httpd.conf
http://codetidy.com/3686/
(3)php.ini
http://codetidy.com/3687/
(4)zmienne środowiskowe:
;C:\xampp\mysql;
;C:\xampp\php
C:\xampp\htdocs\zf\bin

Wcześniej już nie raz tak robiłem i było ok, wszystko ładnie działało bez problemy, a teraz jest ten Error 403 i nie wiem jak ominąć. Błąd 403 to brak uprawnień lub brak pliku index.php, a niby wszystko jest na miejscu.

Oczywiście ogólnie jak stworzę przez zf.bat projekt pod ściezką: C:\xampp\htdocs\Zend to wszystko działa, ale nie chcę tak :) chcę tak jak jest w dokumentacji :)
Jak ściągnę starego xampp'a to trzeba aktualizować phpMyAdami ... bezsensu ...

edytowany 3x, ostatnio: poniatowski, 2012-10-03 13:00
ktoś tu ma nielegalny Windows - dzek69 2012-10-03 13:34
jak nielegalny:P? po czym to wnioskujesz niby :p z uczelni, z MSDN pobrałem ;) - poniatowski 2012-10-03 13:38
Po blokadach w hosts ;] - dzek69 2012-10-03 13:43

Pozostało 580 znaków

2012-10-03 13:33
0

Wyzeruj folder C:\Zend\public, zostaw tam tylko jakis index.html i zobacz czy to się odpali.
Jak masz w tym folderze jakis .htaccess to także pokaż.


Pozostało 580 znaków

2012-10-03 13:35
0

.htaccess z C:\Zend\public


RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]

Usunąłem wszystko z folderu C:\Zend, zostawiłem index.php z echo 'test' i zmieniłem ścieżkę w httpd-hosts.conf na C:\Zend i nic :/

edytowany 1x, ostatnio: poniatowski, 2012-10-03 13:37

Pozostało 580 znaków

2012-10-03 13:39
0
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]

Te dwie regułki się "nadgrywają" (edit: w sumie nie do końca, bo druga już nie podlega warunkom, z tego co kojarzę (ja mam htaccessy proste)). Nie mam zielonego pojęcia jednak czemu ma służyć ta pierwsza. Wygląda na niepoprawną, więc wykomentuj/usuń ją.

Edit:
Okej, nie zauważyłem dopisku niżej. Czyli coś nie tak z konfiguracją. A co Ci się odpala pod http://127.0.0.1/?
Btw: www.zend raczej Ci nie zadziała, chyba, że nowe Windowsy subdomeny kierują na adres domen nadrzędnych z automatu (nie sądzę) (nie masz takiego wpisu w hosts).

Edit:
Podaj lokalizację (pełną) plików: httpd.conf, httpd-vhost.conf


edytowany 6x, ostatnio: dzek69, 2012-10-03 13:46
odpala się normalnie xampp - poniatowski 2012-10-03 13:45
z www zgodzę sie, ale zeszta powinna śmigać, kilka razy już tworzyłem hvhosy i bylo git, pobralem nowego, najnowszego xampp'a i kaplica :/ - poniatowski 2012-10-03 13:47
C:\xampp\apache\conf\ <- tu jest httpd C:\xampp\apache\conf\extra <-a tu jest httpd-vhost - poniatowski 2012-10-03 13:48

Pozostało 580 znaków

2012-10-03 13:53
0

Staraj się raczej odpisywać normalnie, ułatwia to komunikację. Komentarze tylko jak jest taki mały komentarz odnośnie tego jednego postu (jak moja wzmianka o Windowsie ;p).

Ogólnie to zaczynam się gubić, skoro po wyzerowaniu folderu dalej nie działa jak trzeba.
Ustaw DocumentRoot tak samo jak pierwszy virtual host. Nie zapomnij zrestartować serwera (tak na wszelki wypadek wspomnę, nie obraź się :P)

Edit: Albo w ogóle usuń drugi wpis virtual host. powinno to otworzyć jakiś panel xamppa pod http://zend/


edytowany 1x, ostatnio: dzek69, 2012-10-03 13:54

Pozostało 580 znaków

2012-10-03 13:59
0

ok, masz racje z postami. po usunięciu drugiego vhosta, pod adresem http://zend/ jest xampp ;)

A ten wpis jest ok :Options Indexes FollowSymLinks Includes ExecCGI ??

edytowany 1x, ostatnio: poniatowski, 2012-10-03 14:00

Pozostało 580 znaków

2012-10-03 14:03
0

Może są jakieś błędy w tej wersji xampp v3.1.0.3.1.0, bop we wcześniejszej wersji: xampp 3.0.12 i tym samym systemem wszystko było ok. może przeinstaluje xampp'a na starszego i z głowy :/

Pozostało 580 znaków

2012-10-03 14:07
0

Spróbuj wywalić te wpisy <directory> całkiem i zobacz


Pozostało 580 znaków

2012-10-03 19:07
0

Jak usunę <directory> to tak to przywiesza xampp na dobre, że trzeba jebnąć nową instalkę :/ dalej nie mam rozwiązania ... :(

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0