Problem z .htaccess na serwerze hostingowym

Odpowiedz Nowy wątek
2011-08-02 22:48
0

Witam,
mam problem z publikacją strony na serwerze hostingowym. Zarówno na cba.pl jak i ugu.pl oraz 000webhost.com
Problem leży w niedozwolonej zawartości plików .htaccess
Jak zmodyfikować te pliki, aby ich zawartość była dozwolona i symfony działało poprawinie?
Np. na ugu dostaje komunikat:

Internal Server Error   
Błąd może pojawić się w przypadku użycia niedozwolonych opcji w pliku .htaccess
Dozwolone są opcje z grup: AuthConfig FileInfo Limit Indexes
Przykładowe zmienne, najczęściej wywołujące błąd: "Options"
Więcej informacji tutaj: http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride

Obecnie pliki wyglądają tak:

.htaccess:

<Files ~ ".*">
    Order allow,deny
    Deny from all
</Files>

web/.htaccess:

<Files ~ ".*">
    Order allow,deny
    Allow from all
</Files>

Options +FollowSymLinks +ExecCGI

<IfModule mod_rewrite.c>
  RewriteEngine On

  # uncomment the following line, if you are having trouble
  # getting no_script_name to work
  #RewriteBase /

  # we skip all files with .something
  #RewriteCond %{REQUEST_URI} \..+$
  #RewriteCond %{REQUEST_URI} !\.html$
  #RewriteRule .* - [L]

  # we check if the .html version is here (caching)
  RewriteRule ^$ index.html [QSA]
  RewriteRule ^([^.]+)$ $1.html [QSA]
  RewriteCond %{REQUEST_FILENAME} !-f

  # no, so we redirect to our front web controller
  RewriteRule ^(.*)$ index.php [QSA,L]
</IfModule>

Life is good.

Pozostało 580 znaków

2011-08-03 00:25
0

Sugeruję napisać do supportu z prośbą instalacji symfony lub wybrać w panelu sterowania serwerem ręczną instalacje z listy czy coś w tym stylu...


Programista uczy się całe życie....

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0