[PHP] błędne wyświetlanie tekstu przez echo

0

Posiadam taki kod

if ($pokaz=="zaloguj")
{
    echo "<html><head></head><body>";
    echo "jestes zalogowany";
    echo "</body></html>";
}

Efekt jes następujący:

"; echo "jestes zalogowany"; echo ""; }

Co zrobić aby efekt był taki:
jestes zalogowany

0

Uch. Zamknąć to w tagi <?php ... ?>, co?

0
zły człowiek napisał(a)

Uch. Zamknąć to w tagi <?php ... ?>, co?

To jest zamknięte w tagaach. Pokazałem tylko fragment odpowiedzialny za wyświetlanie tekstu

0

to pokaż większy kawałek, bo ten wydaje się poprawny...

0

To jest kod całego programu. Plik admin.php

<html> <head> </head> <body> <?php error_reporting(E_ALL); session_start(); Session_register("admin"); //require("./funkcje.php"); include('funkcje.php'); if ($HTTP_POST_VARS["strona"]=="") { $strona=$HTTP_GET_VARS["strona"]; } else { $strona=$HTTP_POST_VARS["strona"]; } If ($pokaz=="") { echo "djbnan"; } if ($pokaz=="sprawdz") { If ($HTTP_POST_VARS ["login"]== "admin" && $HTTP_POST_VARS ["haslo"]=="haslo") { echo "jestes zalogowany"; } else { echo "Blad"; } } else { echo "Wielki blad"; } ?> </body> </html>

oraz pli funkcje.php z kodem

<html><head></head><body> <?php function admin_log() { echo "

"; echo "<form name="logowanie" action="admin.php" method="post">"; echo "Login: <input type="text" name="login">
"; echo "Hasło: <input type="password" name="haslo">
"; echo "<input type="hidden" name="strona" value="sprawdz">"; echo "<input type="submit" value="Zaloguj">"; echo "

"; } ?> </body></html>

Po wywolaniu pliku funkcje.php to wyświetla mi pustą białą stronę.

0

no to po chelere masz HTML w pliku który includujesz? wywal <html><head></head><body> i </body></html> z pliku funkcje.php

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0