Program nie uruchamia się ..

0

Witam, mam problem dojść nietypowy. Windows 10 Home x64 zainstalowane na 2 takich samych sprzętach na jednym program działa, a na drugim po uruchomieniu pojawia się na chwilę w menadżerze zadań i zamyka się ... w nawiasie przy nazwie procesu (wstrzymany). ktoś tak miał ? jak to naprawić ?
program kompilowany w visual studio 2017

0

Wejdź w "podgląd zdarzeń", tam możliwe, że dostaniesz stacktrace błędu albo i plik DMP, żebyś załadował sobie i zobaczył, co jest nie tak.

0

z podglądu zdarzeń mam taki błąd.

.Net Runtime

Aplikacja: Konsolidacja_PL.exe
Wersja architektury: v4.0.30319
Opis: proces został przerwany z powodu nieobsłużonego wyjątku.
Informacje o wyjątku: System.DllNotFoundException
   w Gecko.Xpcom.Alloc(IntPtr)
   w Gecko.nsAString..ctor()
   w Gecko.nsAString..ctor(System.String)
   w Gecko.Xpcom.Initialize(System.String)
   w Konsolidacja_PL.Form1..ctor()
   w Konsolidacja_PL.Program.Main()

Application Error

Nazwa aplikacji powodującej błąd: Konsolidacja_PL.exe, wersja: 1.0.0.0, sygnatura czasowa: 0xb80f0c56
Nazwa modułu powodującego błąd: KERNELBASE.dll, wersja: 10.0.17134.165, sygnatura czasowa: 0xfa43f4b2
Kod wyjątku: 0xe0434352
Przesunięcie błędu: 0x0010ddc2
Identyfikator procesu powodującego błąd: 0x17e0
Godzina uruchomienia aplikacji powodującej błąd: 0x01d44e6442c07f04
Ścieżka aplikacji powodującej błąd: C:\Users\Konsolidacja_PL\Desktop\Konsolidacja_v1\Release\Konsolidacja_PL.exe
Ścieżka modułu powodującego błąd: C:\WINDOWS\System32\KERNELBASE.dll
Identyfikator raportu: 869c14f8-44cd-49d5-9f59-2ca37df4a19a
Pełna nazwa pakietu powodującego błąd: 
Identyfikator aplikacji względem pakietu powodującego błąd: 

z debuggera w załączniku

1

Masz System.DllNotFoundException występujące w Gecko.Xpcom.Alloc. Prawdopodobnie nie dołączyłeś do swojej aplikacji jakiegoś pliku DLL wymaganego przez twoją aplikację (albo jakieś zależności w rodzaju vcredist w odpowiedniej wersji).

Spójrz na przykład na to: https://stackoverflow.com/que[...]e-system-dllnotfoundexception

0

rzeczywiście vcredist nie był zainstalowany. caly folder z dll Firefox gecko jest skopiowany. jutro spróbuję zainstalować i zobaczymy czy dziala. ale pytanie czemu na innych na których też nie był zainstalowany a działa bez zarzutu ?

0

Dzięki za pomoc ! u mnie to samo było

0

zainstalowanie Visual C++ Redistributable for Visual Studio 2013 pomogło. Dziękuje wszystkim za pomoc, pozdrawiam :)

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0