Dlaczego wyświetla się błąd przy użyciu require-once?

Odpowiedz Nowy wątek
2014-12-18 22:50
0

Jak używam funkcji require-once wywala mi błąd

"Warning: require_once(xxxxxxxxx) [function.require-once]: failed to open stream: No such file or directory "
i drugi

Fatal error: require_once() [function.require]: Failed opening required 'praca xxxxxxx' (include_path='.;C:\php\pear')

<!doctype html>
<html>
    <head>
        <<meta charset="UTF-8">
        <title>Wydajność</title>
        <div id="top">
            <header id="NAGLOWEK">Nagłówek szablonu</header>
            <nav id="MENU">Menu nawigacyjne <?php require_once("xxxxxxxxxx"); ?></nav>
 
            <aside id="INFORMACJE">Dodatkowe informacje</aside>
            <article id="TRESC">Treść strony</article>
            <footer id="STOPKA"></footer>
        </div>
    </head>
    <body>
    </body>
</html>

dodanie znaczników <code> - @furious programming

edytowany 1x, ostatnio: furious programming, 2014-12-18 23:21
hmmm... ciekawe co oznacza ten pierwszy komunikat :) hmmmmm tutaj masz rozwiązanie problemu http://www.ling.pl - axelbest 2014-12-19 00:21

Pozostało 580 znaków

2014-12-19 09:57
2

Bardziej się już nie da wytłumaczyć co jest nie tak, niż to co dostałeś w komunikacie :) Podajesz błędną ścieżkę do pliku.
I popraw

<<meta charset="UTF-8">

masz tam podwójny nawias "<".
No i poza tym w head nie trzymamy divów, przenieś cały div z id="top" do sekcji body.

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0