problem z label / etykiety

Odpowiedz Nowy wątek
2011-08-19 11:41
0

mam taki kod ktorego nie moge skompilowac dlaczego ?

procedure TForm1.Button1Click(Sender: TObject);
var
i:integer;
begin
label
etykieta;
 
goto etykieta;
 
end;

nie dziala

edytowany 1x, ostatnio: madmike, 2011-08-19 15:10
Mały note: 1.kod dajemy w znacznikach <.code> . 2.Raczej nie używamy label. 3.Nie działać to może twój rower, podajemy kody błędów itd. itp. Zapamiętasz? mam nadzieję. - payl 2011-08-19 14:44
@payl: to nie jest podwód, żeby zgłaszać post do moderacji... "Ta strona służy jedynie do raportowania aktów wandalizmów, wulgaryzmów czy innego nieprawidłowego zachowania łamiącego regulamin. Prosimy nie używać jej do zgłaszania błędów, podziękowań itp." Bądź łaskaw wstrzymać sie z raportowaniem drobiazgów :] - madmike 2011-08-19 15:10
No jak dla mnie to nie jest drobiazg, ale spróbuję używać tej mojej ulubionej opcji (ktoś się potrudzi za mnie) rzadziej. :D - payl 2011-08-19 15:20
Nie widzę "aktów wandalizmu", "wulgaryzmów" czy "nieprawidłowego zachowania"... pochodź sobie po forum - sporo osób nie lubi kolorowania tekstu - nawet tych "sprytniejszych"... - madmike 2011-08-19 15:26
no to było nieprawidłowe zachowanie, skoro nie użył <.code> (nie wspominając o łamaniu regulaminu) ... ale dobra, modzi zawsze mają rację eheh. A co do chodzenia po forum - bez obaw, 'chodzę'. :P - payl 2011-08-19 15:31

Pozostało 580 znaków

2011-08-19 12:38

Wyrzuć to "nie dziala" na końcu i może zadziała :P
EDIT:
Niech Ci będzie. Label powinno być przed begin. W kodzie ponadto musisz umieścić tą etykietę "etykieta:" tak chyba było.

PS. Nie używaj label ani goto
PS2. Pisz jaśniej posty, bo to co naskrobałeś to tylko na drwiny zasługuje

edytowany 1x, ostatnio: Sarrus, 2011-08-19 13:53

Pozostało 580 znaków

Odpowiedz
Liczba odpowiedzi na stronę

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0